Browse Source

node: update to v4.4.4

While we're at it, also enable parallel builds.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
lilik-openwrt-22.03
Matthias Schiffer 9 years ago
parent
commit
9125c3615f
No known key found for this signature in database GPG Key ID: 16EF3F64CB201D9C
5 changed files with 22 additions and 21 deletions
  1. +7
    -3
      lang/node/Makefile
  2. +12
    -0
      lang/node/patches/001-hardfloat.patch
  3. +0
    -15
      lang/node/patches/001-mips-no-fpu.patch
  4. +1
    -1
      lang/node/patches/002-addr_info.patch
  5. +2
    -2
      lang/node/patches/003-path.patch

+ 7
- 3
lang/node/Makefile View File

@ -8,17 +8,21 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=node
PKG_VERSION:=v0.12.13
PKG_VERSION:=v4.4.4
PKG_RELEASE:=1
PKG_SOURCE:=node-$(PKG_VERSION).tar.gz
PKG_SOURCE:=node-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://nodejs.org/dist/${PKG_VERSION}
PKG_MD5SUM:=1ad7915688df85f62a57f43860dc54c6
HOST_BUILD_DEPENDS:=python/host
PKG_BUILD_DEPENDS:=python/host
PKG_INSTALL:=1
PKG_USE_MIPS16:=0
HOST_BUILD_PARALLEL:=1
PKG_BUILD_PARALLEL:=1
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
PKG_LICENSE:=
@ -31,7 +35,7 @@ define Package/node
SUBMENU:=Node.js
TITLE:=Node.js is a platform built on Chrome's JavaScript runtime
URL:=http://nodejs.org/
DEPENDS:=+libpthread +librt +libstdcpp +libopenssl +libuv
DEPENDS:=+libpthread +librt +libstdcpp +libopenssl +libuv +zlib
endef
define Package/node/description


+ 12
- 0
lang/node/patches/001-hardfloat.patch View File

@ -0,0 +1,12 @@
diff --git a/deps/v8/src/base/cpu.cc b/deps/v8/src/base/cpu.cc
index 4f58720..1f3071e 100644
--- a/deps/v8/src/base/cpu.cc
+++ b/deps/v8/src/base/cpu.cc
@@ -143,6 +143,7 @@ int __detect_fp64_mode(void) {
".set push\n\t"
".set noreorder\n\t"
".set oddspreg\n\t"
+ ".set hardfloat\n\t"
"lui $t0, 0x3FF0\n\t"
"ldc1 $f0, %0\n\t"
"mtc1 $t0, $f1\n\t"

+ 0
- 15
lang/node/patches/001-mips-no-fpu.patch View File

@ -1,15 +0,0 @@
--- a/deps/v8/build/toolchain.gypi
+++ b/deps/v8/build/toolchain.gypi
@@ -50,10 +50,10 @@
'arm_test_noprobe%': 'off',
# Similar to vfp but on MIPS.
- 'v8_can_use_fpu_instructions%': 'true',
+ 'v8_can_use_fpu_instructions%': 'false',
# Similar to the ARM hard float ABI but on MIPS.
- 'v8_use_mips_abi_hardfloat%': 'true',
+ 'v8_use_mips_abi_hardfloat%': 'false',
# Default arch variant for MIPS.
'mips_arch_variant%': 'r2',

+ 1
- 1
lang/node/patches/002-addr_info.patch View File

@ -1,6 +1,6 @@
--- a/deps/uv/src/unix/getaddrinfo.c
+++ b/deps/uv/src/unix/getaddrinfo.c
@@ -99,6 +99,7 @@
@@ -99,6 +99,7 @@ static void uv__getaddrinfo_work(struct
int err;
req = container_of(w, uv_getaddrinfo_t, work_req);


+ 2
- 2
lang/node/patches/003-path.patch View File

@ -1,7 +1,7 @@
--- a/lib/module.js
+++ b/lib/module.js
@@ -512,7 +512,8 @@
var homeDir = process.env.HOME;
@@ -453,7 +453,8 @@ Module._initPaths = function() {
homeDir = process.env.HOME;
}
- var paths = [path.resolve(process.execPath, '..', '..', 'lib', 'node')];


Loading…
Cancel
Save