OpenVSwitch patch updatelilik-openwrt-22.03
@ -0,0 +1,41 @@ | |||||
From 36fd4f214f9ba74aaf0e5fb3e4ba271b946a1550 Mon Sep 17 00:00:00 2001 | |||||
From: Thomas Graf <tgraf@noironetworks.com> | |||||
Date: Wed, 26 Nov 2014 15:52:31 +0100 | |||||
Subject: [PATCH] datapath: Use ccflags-y instead of deprecated EXTRA_CFLAGS | |||||
This allows users to pass in additional compiler flags through the | |||||
environment variable EXTRA_CFLAGS, e.g. | |||||
make EXTRA_CFLAGS=-Wno-error=foo V=1 | |||||
Reported-by: Alexandru Ardelean <ardeleanalex@gmail.com> | |||||
Signed-off-by: Thomas Graf <tgraf@noironetworks.com> | |||||
Acked-by: Pravin B Shelar <pshelar@nicira.com> | |||||
--- | |||||
datapath/linux/Kbuild.in | 10 +++++----- | |||||
1 file changed, 5 insertions(+), 5 deletions(-) | |||||
diff --git a/datapath/linux/Kbuild.in b/datapath/linux/Kbuild.in | |||||
index 6f6f65f..cb98c11 100644 | |||||
--- a/datapath/linux/Kbuild.in | |||||
+++ b/datapath/linux/Kbuild.in | |||||
@@ -7,11 +7,11 @@ export VERSION = @VERSION@ | |||||
include $(srcdir)/../Modules.mk | |||||
include $(srcdir)/Modules.mk | |||||
-EXTRA_CFLAGS := -DVERSION=\"$(VERSION)\" | |||||
-EXTRA_CFLAGS += -I$(srcdir)/.. | |||||
-EXTRA_CFLAGS += -I$(builddir)/.. | |||||
-EXTRA_CFLAGS += -g | |||||
-EXTRA_CFLAGS += -include $(builddir)/kcompat.h | |||||
+ccflags-y := -DVERSION=\"$(VERSION)\" | |||||
+ccflags-y += -I$(srcdir)/.. | |||||
+ccflags-y += -I$(builddir)/.. | |||||
+ccflags-y += -g | |||||
+ccflags-y += -include $(builddir)/kcompat.h | |||||
# These include directories have to go before -I$(KSRC)/include. | |||||
# NOSTDINC_FLAGS just happens to be a variable that goes in the | |||||
-- | |||||
2.1.2 | |||||
@ -1,39 +0,0 @@ | |||||
From deb44e6e9d64001562ee9395a2c8525848052394 Mon Sep 17 00:00:00 2001 | |||||
From: Alexandru Ardelean <aa@ocedo.com> | |||||
Date: Tue, 28 Oct 2014 11:03:53 +0200 | |||||
Subject: [PATCH] datapath/linux: add KCFLAGS var to modules Makefile.main.in | |||||
This is mostly required because of GCC 4.9 which seems | |||||
to error out with: | |||||
openvswitch/datapath/linux/datapath.c:2108:10: | |||||
error: macro "DATE" might prevent reproducible builds | |||||
We would have wanted to add '-Wno-error=date-time' directly | |||||
but that would be too specific, so we decided to add | |||||
a generic make flag and configure it with what we need. | |||||
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com> | |||||
--- | |||||
datapath/linux/Makefile.main.in | 4 ++-- | |||||
1 file changed, 2 insertions(+), 2 deletions(-) | |||||
diff --git a/datapath/linux/Makefile.main.in b/datapath/linux/Makefile.main.in | |||||
index 88f144c..0b200b7 100644 | |||||
--- a/datapath/linux/Makefile.main.in | |||||
+++ b/datapath/linux/Makefile.main.in | |||||
@@ -67,10 +67,10 @@ ifeq (,$(wildcard $(CONFIG_FILE))) | |||||
endif | |||||
default: | |||||
- $(MAKE) -C $(KSRC) M=$(builddir) modules | |||||
+ $(MAKE) -C $(KSRC) M=$(builddir) $(KCFLAGS) modules | |||||
modules_install: | |||||
- $(MAKE) -C $(KSRC) M=$(builddir) modules_install | |||||
+ $(MAKE) -C $(KSRC) M=$(builddir) $(KCFLAGS) modules_install | |||||
depmod `sed -n 's/#define UTS_RELEASE "\([^"]*\)"/\1/p' $(KSRC)/include/generated/utsrelease.h` | |||||
endif | |||||
-- | |||||
1.8.4.5 | |||||