Browse Source

python: add patch to remove Debian/Ubuntu multiarch support

Seems when cross compiling on x86_64 Debian (most likely Ubuntu too)
the host's paths will be added too causing build failures for some extensions.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lilik-openwrt-22.03
Alexandru Ardelean 10 years ago
parent
commit
903432c91e
1 changed files with 12 additions and 0 deletions
  1. +12
    -0
      lang/python/patches/160-remove-debian-multiarch-support.patch

+ 12
- 0
lang/python/patches/160-remove-debian-multiarch-support.patch View File

@ -0,0 +1,12 @@
diff --git a/setup.py b/setup.py
index 7868b7b..9ae0ef2 100644
--- a/setup.py
+++ b/setup.py
@@ -444,7 +444,6 @@ class PyBuildExt(build_ext):
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
if cross_compiling:
self.add_gcc_paths()
- self.add_multiarch_paths()
# Add paths specified in the environment variables LDFLAGS and
# CPPFLAGS for header and library files.

Loading…
Cancel
Save