Browse Source
Merge pull request #7844 from neheb/cn
conserver: Fix compilation without deprecated OpenSSL 1.0.2 APIs
lilik-openwrt-22.03
Hannu Nyman
6 years ago
committed by
GitHub
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with
12 additions and
1 deletions
-
net/conserver/Makefile
-
net/conserver/patches/010-openssl-deprecated.patch
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
|
PKG_NAME:=conserver |
|
|
PKG_NAME:=conserver |
|
|
PKG_VERSION:=8.2.2 |
|
|
PKG_VERSION:=8.2.2 |
|
|
PKG_RELEASE:=1 |
|
|
|
|
|
|
|
|
PKG_RELEASE:=2 |
|
|
PKG_MAINTAINER:=Bjørn Mork <bjorn@mork.no> |
|
|
PKG_MAINTAINER:=Bjørn Mork <bjorn@mork.no> |
|
|
|
|
|
|
|
|
PKG_SOURCE_PROTO:=git |
|
|
PKG_SOURCE_PROTO:=git |
|
|
|
@ -0,0 +1,11 @@ |
|
|
|
|
|
--- a/conserver/cutil.h
|
|
|
|
|
|
+++ b/conserver/cutil.h
|
|
|
|
|
|
@@ -7,6 +7,8 @@
|
|
|
|
|
|
#include <stdarg.h> |
|
|
|
|
|
#if HAVE_OPENSSL |
|
|
|
|
|
# include <openssl/ssl.h> |
|
|
|
|
|
+# include <openssl/bn.h>
|
|
|
|
|
|
+# include <openssl/dh.h>
|
|
|
|
|
|
# include <openssl/err.h> |
|
|
|
|
|
# if OPENSSL_VERSION_NUMBER < 0x10100000L |
|
|
|
|
|
# define TLS_method SSLv23_method |