Browse Source

python3: patch setup.py so that it does not include system include dirs

Seems that the Python C extensions were being
(or at least trying to be) build using '/usr/include' as the first
include folder.

Seems this issue was already fixed on MacOS X and now we've extended
it for our case.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lilik-openwrt-22.03
Alexandru Ardelean 10 years ago
parent
commit
8c4da0367b
1 changed files with 14 additions and 0 deletions
  1. +14
    -0
      lang/python3/patches/120-do-not-add-include-dirs-when-cross-compiling.patch

+ 14
- 0
lang/python3/patches/120-do-not-add-include-dirs-when-cross-compiling.patch View File

@ -0,0 +1,14 @@
diff --git a/setup.py b/setup.py
index 93f390f..ace1494 100644
--- a/setup.py
+++ b/setup.py
@@ -461,7 +461,8 @@ class PyBuildExt(build_ext):
add_dir_to_list(dir_list, directory)
if os.path.normpath(sys.base_prefix) != '/usr' \
- and not sysconfig.get_config_var('PYTHONFRAMEWORK'):
+ and not sysconfig.get_config_var('PYTHONFRAMEWORK') \
+ and not cross_compiling:
# OSX note: Don't add LIBDIR and INCLUDEDIR to building a framework
# (PYTHONFRAMEWORK is set) to avoid # linking problems when
# building a framework with different architectures than

Loading…
Cancel
Save