Bump getdns/stubby to 1.7.0 and 0.4.0 respectivelylilik-openwrt-22.03
@ -1,13 +0,0 @@ | |||
--- a/src/tls/val_secalgo.c | |||
+++ b/src/tls/val_secalgo.c | |||
@@ -72,6 +72,10 @@ | |||
#include <openssl/engine.h> | |||
#endif | |||
+#ifdef USE_DSA | |||
+#include <openssl/dsa.h> | |||
+#endif | |||
+ | |||
/** fake DSA support for unit tests */ | |||
int fake_dsa = 0; | |||
/** fake SHA1 support for unit tests */ |
@ -1,57 +0,0 @@ | |||
--- a/CMakeLists.txt | |||
+++ b/CMakeLists.txt | |||
@@ -334,6 +334,9 @@ check_include_file(openssl/err.h HAVE_OP | |||
check_include_file(openssl/rand.h HAVE_OPENSSL_RAND_H) | |||
check_include_file(openssl/conf.h HAVE_OPENSSL_CONF_H) | |||
check_include_file(openssl/engine.h HAVE_OPENSSL_ENGINE_H) | |||
+check_include_file(openssl/bn.h HAVE_OPENSSL_BN_H) | |||
+check_include_file(openssl/dsa.h HAVE_OPENSSL_DSA_H) | |||
+check_include_file(openssl/rsa.h HAVE_OPENSSL_RSA_H) | |||
set(CMAKE_REQUIRED_LIBRARIES ${OPENSSL_LIBRARIES}) | |||
check_function_exists(DSA_SIG_set0 HAVE_DSA_SIG_SET0) | |||
--- a/cmake/include/cmakeconfig.h.in | |||
+++ b/cmake/include/cmakeconfig.h.in | |||
@@ -58,6 +58,9 @@ | |||
#cmakedefine HAVE_OPENSSL_RAND_H 1 | |||
#cmakedefine HAVE_OPENSSL_CONF_H 1 | |||
#cmakedefine HAVE_OPENSSL_ENGINE_H 1 | |||
+#cmakedefine HAVE_OPENSSL_BN_H 1 | |||
+#cmakedefine HAVE_OPENSSL_DSA_H 1 | |||
+#cmakedefine HAVE_OPENSSL_RSA_H 1 | |||
#cmakedefine HAVE_DSA_SIG_SET0 1 | |||
#cmakedefine HAVE_DSA_SET0_PQG 1 | |||
--- a/src/openssl/keyraw-internal.c | |||
+++ b/src/openssl/keyraw-internal.c | |||
@@ -21,10 +21,10 @@ | |||
#include <openssl/err.h> | |||
#include <openssl/md5.h> | |||
#ifdef HAVE_OPENSSL_CONF_H | |||
-# include <openssl/conf.h> | |||
+#include <openssl/conf.h> | |||
#endif | |||
#ifdef HAVE_OPENSSL_ENGINE_H | |||
-# include <openssl/engine.h> | |||
+#include <openssl/engine.h> | |||
#endif | |||
#ifdef HAVE_OPENSSL_BN_H | |||
#include <openssl/bn.h> | |||
@@ -35,6 +35,9 @@ | |||
#ifdef HAVE_OPENSSL_DSA_H | |||
#include <openssl/dsa.h> | |||
#endif | |||
+#ifdef HAVE_OPENSSL_RSA_H | |||
+#include <openssl/rsa.h> | |||
+#endif | |||
#endif /* HAVE_SSL */ | |||
#ifdef HAVE_SSL | |||
@@ -74,7 +77,6 @@ gldns_key_EVP_load_gost_id(void) | |||
if(!e) { | |||
/* load it ourself, in case statically linked */ | |||
ENGINE_load_builtin_engines(); | |||
- ENGINE_load_dynamic(); | |||
e = ENGINE_by_id("gost"); | |||
} | |||
if(!e) { |
@ -1,13 +0,0 @@ | |||
--- a/cmake/include/cmakeconfig.h.in | |||
+++ b/cmake/include/cmakeconfig.h.in | |||
@@ -91,8 +91,8 @@ | |||
#cmakedefine HAVE_OPENSSL_VERSION 1 | |||
#cmakedefine HAVE_SSL_CTX_DANE_ENABLE 1 | |||
-#cmakedefine HAVE_SSL_CTX_SET_CIPHERSUITS 1 | |||
-#cmakedefine HAVE_SSL_SET_CIPHERSUITS 1 | |||
+#cmakedefine HAVE_SSL_CTX_SET_CIPHERSUITES 1 | |||
+#cmakedefine HAVE_SSL_SET_CIPHERSUITES 1 | |||
#cmakedefine HAVE_OPENSSL_INIT_CRYPTO 1 | |||
@ -1,11 +0,0 @@ | |||
--- a/CMakeLists.txt | |||
+++ b/CMakeLists.txt | |||
@@ -523,7 +523,7 @@ set(STRPTIME_TEST_SOURCE "\n | |||
res = strptime(\"20070207111842\", \"%Y%m%d%H%M%S\", &tm);\n | |||
if (!res) return 1; return 0; }") | |||
-if (HAVE_STRPTIME) | |||
+if (HAVE_STRPTIME AND NOT CMAKE_CROSSCOMPILING) | |||
check_c_source_runs("${STRPTIME_TEST_SOURCE}" STRPTIME_WORKS) | |||
endif () | |||
@ -1,35 +0,0 @@ | |||
--- a/CMakeLists.txt | |||
+++ b/CMakeLists.txt | |||
@@ -115,14 +115,26 @@ install(FILES AUTHORS COPYING ChangeLog | |||
# Ensure the file gets CRLF line endings on Windows. | |||
file(GENERATE OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/stubby.yml INPUT ${CMAKE_CURRENT_SOURCE_DIR}/stubby.yml.example) | |||
-# Copy to destination iff no destination file exists. | |||
+ | |||
+# Copy stubby.yml to destination iff no destination file exists. | |||
+# This is complicated by (a) not being able to use generators, due to | |||
+# CMake minimum version requirement, and (b) to account for DESTDIR. | |||
+# And in the latter case, if we're adding DESTDIR to the start of the | |||
+# path, we must on Windows remove any initial drive letter. That's what | |||
+# INSTALL appears to do. | |||
install(CODE "\ | |||
- set(targetdir ${STUBBYCONFDIR})\n\ | |||
- if (\$ENV{DESTDIR})\n\ | |||
- set(targetdir \$ENV{DESTDIR}/\${targetdir})\n\ | |||
+ set(targetdir \"${STUBBYCONFDIR}\")\n\ | |||
+ set(destdir \"\$ENV{DESTDIR}\")\n\ | |||
+ if (destdir)\n\ | |||
+ string(REGEX REPLACE \"^([A-Z]:)?/(.*)\" \"\\\\2\" newtarget \"\${targetdir}\")\n\ | |||
+ if (newtarget)\n\ | |||
+ set(targetdir \"\${newtarget}\")\n\ | |||
+ endif ()\n\ | |||
+ set(targetdir \"\${destdir}/\${newtarget}\")\n\ | |||
endif ()\n\ | |||
- if (NOT EXISTS \${targetdir}/stubby.yml)\n\ | |||
- file(COPY ${CMAKE_CURRENT_BINARY_DIR}/stubby.yml DESTINATION \${targetdir})\n\ | |||
+ if (NOT EXISTS \"\${targetdir}/stubby.yml\")\n\ | |||
+ file(COPY \"${CMAKE_CURRENT_BINARY_DIR}/stubby.yml\" DESTINATION \"\${targetdir}\")\n\ | |||
+ message(\"-- Installing: \${targetdir}/stubby.yml\")\n\ | |||
endif ()") | |||
if (APPLE) |