Browse Source

gnunet: update to version 0.11.7

Backport dist bug and add missing header file.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
lilik-openwrt-22.03
Daniel Golle 5 years ago
parent
commit
8bee758bc0
2 changed files with 92 additions and 10 deletions
  1. +6
    -10
      net/gnunet/Makefile
  2. +86
    -0
      net/gnunet/patches/001-include-pq-h-in-dist.patch

+ 6
- 10
net/gnunet/Makefile View File

@ -2,11 +2,11 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gnunet
PKG_VERSION:=0.11.6
PKG_VERSION:=0.11.7
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/gnunet
PKG_HASH:=f8a07063b1e0890a1386fed2313a967f58f5495c075a25725aba200469c857bf
PKG_HASH:=13ffe47232f12e8f5ae2172651b123c816446c879d20c7acc72479872045eee5
PKG_LICENSE:=AGPL-3.0
PKG_LICENSE_FILES:=COPYING
@ -33,13 +33,14 @@ CONFIGURE_ARGS+= \
--enable-experimental \
--with-extractor=$(STAGING_DIR)/usr \
--with-gnutls=$(STAGING_DIR)/usr \
$(if $(CONFIG_PACKAGE_$(PKG_NAME)-transport-bluetooth),--with-libbluetooth="$(STAGING_DIR)/usr",--without-libbluetooth) \
--with-libgnurl=$(STAGING_DIR)/usr \
--with-libogg=$(STAGING_DIR)/usr \
--with-libopus=$(STAGING_DIR)/usr \
--with-libpulse=$(STAGING_DIR)/usr \
--with-libunistring-prefix=$(STAGING_DIR)/usr \
--with-microhttpd=$(STAGING_DIR)/usr
# ToDo: request upstream to provide --with-pulseaudio=...
TARGET_LDFLAGS+= -Wl,-rpath-link=$(STAGING_DIR)/usr/lib/pulseaudio
define Package/gnunet/Default
SECTION:=net
CATEGORY:=Network
@ -222,10 +223,6 @@ PLUGIN_transport-udp:=transport_udp
PLUGIN_transport-wlan:=transport_wlan
LIBEXEC_transport-wlan:=helper-transport-wlan
DEPENDS_experiments:=+libglpk
PLUGIN_experiments:=ats_mlp ats_ril
# BIN_dv:=dv
LIB_dv:=dv
PLUGIN_dv:=transport_dv
@ -394,7 +391,6 @@ $(eval $(call BuildComponent,curl,cURL wrapper component,))
$(eval $(call BuildComponent,datastore,data storage components,))
$(eval $(call BuildComponent,dht-cli,DHT command line clients,))
# $(eval $(call BuildComponent,dv,distance-vector routing component,y))
$(eval $(call BuildComponent,experiments,experimental components,))
$(eval $(call BuildComponent,fs,file-sharing components,))
$(eval $(call BuildComponent,gns,name resolution components,y))
$(eval $(call BuildComponent,gns-proxy,gns-proxy component,))


+ 86
- 0
net/gnunet/patches/001-include-pq-h-in-dist.patch View File

@ -0,0 +1,86 @@
Index: gnunet-0.11.7/src/pq/pq.h
===================================================================
--- /dev/null
+++ gnunet-0.11.7/src/pq/pq.h
@@ -0,0 +1,57 @@
+/*
+ This file is part of GNUnet
+ Copyright (C) 2017, 2019 GNUnet e.V.
+
+ GNUnet is free software: you can redistribute it and/or modify it
+ under the terms of the GNU Affero General Public License as published
+ by the Free Software Foundation, either version 3 of the License,
+ or (at your option) any later version.
+
+ GNUnet is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Affero General Public License for more details.
+
+ You should have received a copy of the GNU Affero General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+ SPDX-License-Identifier: AGPL3.0-or-later
+ */
+/**
+ * @file pq/pq.h
+ * @brief shared internal data structures of libgnunetpq
+ * @author Christian Grothoff
+ */
+#ifndef PQ_H
+#define PQ_H
+
+#include "gnunet_util_lib.h"
+#include "gnunet_pq_lib.h"
+
+/**
+ * Handle to Postgres database.
+ */
+struct GNUNET_PQ_Context
+{
+ /**
+ * Actual connection.
+ */
+ PGconn *conn;
+
+ /**
+ * Statements to execute upon connection.
+ */
+ struct GNUNET_PQ_ExecuteStatement *es;
+
+ /**
+ * Prepared statements.
+ */
+ struct GNUNET_PQ_PreparedStatement *ps;
+
+ /**
+ * Configuration to use to connect to the DB.
+ */
+ char *config_str;
+};
+
+#endif
Index: gnunet-0.11.7/src/pq/Makefile.am
===================================================================
--- gnunet-0.11.7.orig/src/pq/Makefile.am
+++ gnunet-0.11.7/src/pq/Makefile.am
@@ -11,6 +11,7 @@ endif
libgnunetpq_la_SOURCES = \
pq.c \
+ pq.h \
pq_connect.c \
pq_eval.c \
pq_exec.c \
Index: gnunet-0.11.7/src/pq/Makefile.in
===================================================================
--- gnunet-0.11.7.orig/src/pq/Makefile.in
+++ gnunet-0.11.7/src/pq/Makefile.in
@@ -641,6 +641,7 @@ AM_CPPFLAGS = -I$(top_srcdir)/src/includ
@HAVE_POSTGRESQL_TRUE@lib_LTLIBRARIES = libgnunetpq.la
libgnunetpq_la_SOURCES = \
pq.c \
+ pq.h \
pq_connect.c \
pq_eval.c \
pq_exec.c \

Loading…
Cancel
Save