|
|
@ -0,0 +1,35 @@ |
|
|
|
From b6d4bff30f2bdc3a6f26c9f6c7f32e352270d119 Mon Sep 17 00:00:00 2001 |
|
|
|
From: Yousong Zhou <yszhou4tech@gmail.com> |
|
|
|
Date: Sat, 24 Feb 2018 13:46:31 +0800 |
|
|
|
Subject: [PATCH 3/3] pc-bios: fix compilation when $(AS) is actually gcc |
|
|
|
driver |
|
|
|
|
|
|
|
---
|
|
|
|
pc-bios/optionrom/Makefile | 4 ++-- |
|
|
|
1 file changed, 2 insertions(+), 2 deletions(-) |
|
|
|
|
|
|
|
diff --git a/pc-bios/optionrom/Makefile b/pc-bios/optionrom/Makefile
|
|
|
|
index a9a9e5e..f88b3ee 100644
|
|
|
|
--- a/pc-bios/optionrom/Makefile
|
|
|
|
+++ b/pc-bios/optionrom/Makefile
|
|
|
|
@@ -34,7 +34,7 @@ endif
|
|
|
|
QEMU_INCLUDES += -I$(SRC_PATH) |
|
|
|
|
|
|
|
Wa = -Wa, |
|
|
|
-ASFLAGS += -32
|
|
|
|
+ASFLAGS += $(Wa)-32
|
|
|
|
QEMU_CFLAGS += $(call cc-c-option, $(QEMU_CFLAGS), $(Wa)-32) |
|
|
|
|
|
|
|
build-all: multiboot.bin linuxboot.bin linuxboot_dma.bin kvmvapic.bin |
|
|
|
@@ -44,7 +44,7 @@ build-all: multiboot.bin linuxboot.bin linuxboot_dma.bin kvmvapic.bin
|
|
|
|
|
|
|
|
|
|
|
|
%.o: %.S |
|
|
|
- $(call quiet-command,$(CPP) $(QEMU_INCLUDES) $(QEMU_DGFLAGS) -c -o - $< | $(AS) $(ASFLAGS) -o $@,"AS","$(TARGET_DIR)$@")
|
|
|
|
+ $(call quiet-command,$(CPP) $(QEMU_INCLUDES) $(QEMU_DGFLAGS) -c -o - $< | $(AS) $(ASFLAGS) -o $@ -x assembler -,"AS","$(TARGET_DIR)$@")
|
|
|
|
|
|
|
|
%.img: %.o |
|
|
|
$(call quiet-command,$(LD) $(LDFLAGS_NOPIE) -m $(LD_I386_EMULATION) -T $(SRC_PATH)/pc-bios/optionrom/flat.lds -s -o $@ $<,"BUILD","$(TARGET_DIR)$@") |
|
|
|
--
|
|
|
|
1.8.3.1 |
|
|
|
|