Browse Source

freeradius3: fix hostname invocation in radtest

Canonical radtest start results in an error:

$ radtest bob hello localhost 0 testing123
/usr/bin/radtest: line 1: hostname: not found
(0) Error parsing "stdin": Failed to get value

hostname command is not present in OpenWrt.
Instead, hostname can be obtained from file /proc/sys/kernel/hostname.

added: 004-get-hostname-from-proc-in-radtest.patch

Signed-off-by: Alexey Dobrovolsky <dobrovolskiy.alexey@gmail.com>
lilik-openwrt-22.03
Alexey Dobrovolsky 4 years ago
parent
commit
8b2792adc9
2 changed files with 13 additions and 1 deletions
  1. +1
    -1
      net/freeradius3/Makefile
  2. +12
    -0
      net/freeradius3/patches/004-get-hostname-from-proc-in-radtest.patch

+ 1
- 1
net/freeradius3/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=freeradius3
PKG_VERSION:=release_3_0_21
PKG_RELEASE:=5
PKG_RELEASE:=6
PKG_SOURCE:=$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/FreeRADIUS/freeradius-server/archive


+ 12
- 0
net/freeradius3/patches/004-get-hostname-from-proc-in-radtest.patch View File

@ -0,0 +1,12 @@
--- a/src/main/radtest.in
+++ b/src/main/radtest.in
@@ -112,7 +112,7 @@ if [ "$7" ]
then
nas=$7
else
- nas=`hostname`
+ nas=$(cat /proc/sys/kernel/hostname)
fi
(

Loading…
Cancel
Save