Browse Source

atftp: fix compilation with newer musl

Added missing header for __THROW.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 4 years ago
parent
commit
89ddb6baca
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 23 additions and 1 deletions
  1. +1
    -1
      net/atftp/Makefile
  2. +22
    -0
      net/atftp/patches/04-cdefs.patch

+ 1
- 1
net/atftp/Makefile View File

@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=atftp
PKG_VERSION:=0.7.2
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)


+ 22
- 0
net/atftp/patches/04-cdefs.patch View File

@ -0,0 +1,22 @@
--- a/argz.h
+++ b/argz.h
@@ -39,6 +39,7 @@
#define _ARGZ_H 1
#include <features.h>
+#include <sys/cdefs.h>
#define __need_error_t
#include <errno.h>
@@ -76,9 +77,9 @@ extern error_t argz_create_sep (__const char *__restrict __string,
/* Returns the number of strings in ARGZ. */
extern size_t __argz_count (__const char *__argz, size_t __len)
- __THROW __attribute_pure__;
+ __THROW;
extern size_t argz_count (__const char *__argz, size_t __len)
- __THROW __attribute_pure__;
+ __THROW;
/* Puts pointers to each string in ARGZ into ARGV, which must be large enough
to hold them all. */

Loading…
Cancel
Save