Browse Source

ibrdtnd: Add patch to exclude build of documentation using pdflatex

By default the package detects the presence of pdflatex and builds documentation automatically.
During the OpenWrt build this behavior is not acceptable. The added patch introduces a configure
option to explicitly enable the build of the documentation on request.

Signed-off-by: Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
lilik-openwrt-22.03
Johannes Morgenroth 10 years ago
parent
commit
896951b852
1 changed files with 26 additions and 0 deletions
  1. +26
    -0
      net/ibrdtnd/patches/110-add_configure_options_docs.patch

+ 26
- 0
net/ibrdtnd/patches/110-add_configure_options_docs.patch View File

@ -0,0 +1,26 @@
--- a/configure.ac
+++ b/configure.ac
@@ -138,11 +138,17 @@ AS_IF([test "x$enable_android" = "xyes"], [
# Checks for library functions.
AC_CHECK_FUNCS([gethostname socket])
- # Check for presence of pdfLaTeX
- AC_CHECK_PROG(PDFLATEX, pdflatex, pdflatex)
- if test -z "$PDFLATEX"; then
- AC_MSG_WARN([Unable to create PDF version of the documentation.])
- fi
+ AC_ARG_ENABLE([docs],
+ AS_HELP_STRING([--enable-docs], [Build documentation using PDFLaTeX]),
+ [
+ # Check for presence of pdfLaTeX
+ AC_CHECK_PROG(PDFLATEX, pdflatex, pdflatex)
+ if test -z "$PDFLATEX"; then
+ AC_MSG_WARN([Unable to create PDF version of the documentation.])
+ fi
+ ], [
+ PDFLATEX="no"
+ ])
AC_ARG_ENABLE([libdaemon],
AS_HELP_STRING([--disable-libdaemon], [Build without libdaemon support]),
--

Loading…
Cancel
Save