Browse Source

perl: Work around recompile failures

Apparently, recompiling/relinking fails under some circumstances. This
patch has been reported to work around that issue.

Signed-off-by: Marcel Denia <naoir@gmx.net>
lilik-openwrt-22.03
Marcel Denia 9 years ago
parent
commit
8829ae3de6
1 changed files with 16 additions and 0 deletions
  1. +16
    -0
      lang/perl/patches/310-recompile-hack.patch

+ 16
- 0
lang/perl/patches/310-recompile-hack.patch View File

@ -0,0 +1,16 @@
perl: Work around recompile failures
Apparently, recompiling/relinking fails under some circumstances. This
patch has been reported to work around that issue.
--- a/Makefile.SH
+++ b/Makefile.SH
@@ -818,7 +818,7 @@ $(LIBPERL): $& $(obj) $(DYNALOADER) $(LI
true)
$spitshell >>$Makefile <<'!NO!SUBS!'
rm -f $@
- $(LD) -o $@ $(SHRPLDFLAGS) $(obj) $(DYNALOADER) $(libs)
+ $(CC) -o $@ $(SHRPLDFLAGS) $(obj) $(DYNALOADER) $(libs)
!NO!SUBS!
case "$osname" in
aix)

Loading…
Cancel
Save