Browse Source

iperf: update to 2.1.3

Switch to AUTORELEASE for simplicity.

Remove upstreamed patches.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 3 years ago
parent
commit
872505d8f9
4 changed files with 3 additions and 59 deletions
  1. +3
    -3
      net/iperf/Makefile
  2. +0
    -20
      net/iperf/patches/0003-fix-non-ipv6-builds.patch
  3. +0
    -12
      net/iperf/patches/010-libcxx.patch
  4. +0
    -24
      net/iperf/patches/020-math.patch

+ 3
- 3
net/iperf/Makefile View File

@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=iperf
PKG_VERSION:=2.0.13
PKG_RELEASE:=3
PKG_VERSION:=2.1.3
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_HASH:=c88adec966096a81136dda91b4bd19c27aae06df4d45a7f547a8e50d723778ad
PKG_HASH:=dfe2197e2842fe9c9d9677bf1cb20a5a9ccfcb9a9de79f9927c39f73204ba003
PKG_SOURCE_URL:=@SF/iperf2
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>


+ 0
- 20
net/iperf/patches/0003-fix-non-ipv6-builds.patch View File

@ -1,20 +0,0 @@
--- a/src/Listener.cpp
+++ b/src/Listener.cpp
@@ -723,6 +723,7 @@ int Listener::L2_setup (void) {
// Now optimize packet flow up the raw socket
// Establish the flow BPF to forward up only "connected" packets to this raw socket
+#ifdef HAVE_IPV6
if (l->sa_family == AF_INET6) {
#ifdef HAVE_IPV6
struct in6_addr *v6peer = SockAddr_get_in6_addr(&server->peer);
@@ -740,6 +741,9 @@ int Listener::L2_setup (void) {
return -1;
#endif /* HAVE_IPV6 */
} else {
+#else
+ {
+#endif
rc = SockAddr_v4_Connect_BPF(server->mSock, ((struct sockaddr_in *)(l))->sin_addr.s_addr, ((struct sockaddr_in *)(p))->sin_addr.s_addr, ((struct sockaddr_in *)(l))->sin_port, ((struct sockaddr_in *)(p))->sin_port);
WARN_errno( rc == SOCKET_ERROR, "l2 connect ip bpf");
}

+ 0
- 12
net/iperf/patches/010-libcxx.patch View File

@ -1,12 +0,0 @@
--- a/config.h.in
+++ b/config.h.in
@@ -360,7 +360,9 @@
#undef _REENTRANT
/* */
+#ifndef __cplusplus
#undef bool
+#endif
/* Define to empty if `const' does not conform to ANSI C. */
#undef const

+ 0
- 24
net/iperf/patches/020-math.patch View File

@ -1,24 +0,0 @@
--- a/src/pdfs.c
+++ b/src/pdfs.c
@@ -80,7 +80,7 @@ float box_muller(void) {
fprintf(stderr, "pdf box_muller() rand() error\n");
return 0;
} else {
- w = sqrt( (-2.0 * log( w ) ) / w );
+ w = sqrt( (-2.0 * logf( w ) ) / w );
y1 = x1 * w;
y2 = x2 * w;
}
@@ -93,8 +93,8 @@ float normal(float mean, float variance)
}
float lognormal(float mu, float sigma) {
- float phi = sqrt((mu * mu) + (sigma * sigma));
- float mu_prime = log(((mu * mu)/phi));
- float sigma_prime = sqrt(log((phi * phi)/(mu * mu)));
- return (exp(normal(mu_prime,sigma_prime)));
+ float phi = sqrtf((mu * mu) + (sigma * sigma));
+ float mu_prime = logf(((mu * mu)/phi));
+ float sigma_prime = sqrtf(logf((phi * phi)/(mu * mu)));
+ return (expf(normal(mu_prime,sigma_prime)));
}

Loading…
Cancel
Save