Browse Source

haproxy: update to version 1.5.11 and pending patches

- BUG/MEDIUM: backend: correctly detect the domain when use_domain_only is used
     - MINOR: ssl: load certificates in alphabetical order
     - BUG/MINOR: checks: prevent http keep-alive with http-check expect
     - BUG/MEDIUM: Do not set agent health to zero if server is disabled in config
     - MEDIUM/BUG: Only explicitly report "DOWN (agent)" if the agent health is zero
     - BUG/MINOR: stats:Fix incorrect printf type.
     - DOC: add missing entry for log-format and clarify the text
     - BUG/MEDIUM: http: fix header removal when previous header ends with pure LF
     - BUG/MEDIUM: channel: fix possible integer overflow on reserved size computation
     - BUG/MINOR: channel: compare to_forward with buf->i, not buf->size
     - MINOR: channel: add channel_in_transit()
     - MEDIUM: channel: make buffer_reserved() use channel_in_transit()
     - MEDIUM: channel: make bi_avail() use channel_in_transit()
     - BUG/MEDIUM: channel: don't schedule data in transit for leaving until connected
     - BUG/MAJOR: log: don't try to emit a log if no logger is set
     - BUG/MINOR: args: add missing entry for ARGT_MAP in arg_type_names
     - BUG/MEDIUM: http: make http-request set-header compute the string before removal
     - BUG/MINOR: http: fix incorrect header value offset in replace-hdr/replace-value
     - BUG/MINOR: http: abort request processing on filter failure
     - BUG/MINOR: pattern: error message missing
     - BUG/MEDIUM: pattern: some entries are not deleted with case insensitive match

Signed-off-by: Thomas Heil <heil@terminal-consulting.de>
lilik-openwrt-22.03
Thomas Heil 10 years ago
parent
commit
8609cc44e7
3 changed files with 71 additions and 3 deletions
  1. +3
    -3
      net/haproxy/Makefile
  2. +30
    -0
      net/haproxy/patches/0001-BUG-MINOR-pattern-error-message-missing.patch
  3. +38
    -0
      net/haproxy/patches/0002-BUG-MEDIUM-pattern-some-entries-are-not-deleted-with.patch

+ 3
- 3
net/haproxy/Makefile View File

@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=haproxy
PKG_VERSION:=1.5.10
PKG_RELEASE:=00
PKG_VERSION:=1.5.11
PKG_RELEASE:=02
PKG_SOURCE:=haproxy-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://haproxy.1wt.eu/download/1.5/src/
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_MD5SUM:=5631457ea1f84b3c0d8e5bc8015ed329
PKG_MD5SUM:=5500a79d0d2b238d4a1e9749bd0c2cb2
PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>
PKG_LICENSE:=GPL-2.0


+ 30
- 0
net/haproxy/patches/0001-BUG-MINOR-pattern-error-message-missing.patch View File

@ -0,0 +1,30 @@
From e338a8741983acc9a4501a03ecd593d89e6fade3 Mon Sep 17 00:00:00 2001
From: Thierry FOURNIER <tfournier@exceliance.fr>
Date: Fri, 6 Feb 2015 17:50:55 +0100
Subject: [PATCH 1/2] BUG/MINOR: pattern: error message missing
This patch must be backported in 1.5 version.
(cherry picked from commit 8aa8384e22dd0b66ded00c70a9c6034278b4bb69)
---
src/pattern.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/src/pattern.c b/src/pattern.c
index 208e33a..a6fc52d 100644
--- a/src/pattern.c
+++ b/src/pattern.c
@@ -989,8 +989,10 @@ int pat_idx_list_ptr(struct pattern_expr *expr, struct pattern *pat, char **err)
/* allocate pattern */
patl = calloc(1, sizeof(*patl));
- if (!patl)
+ if (!patl) {
+ memprintf(err, "out of memory while indexing pattern");
return 0;
+ }
/* duplicate pattern */
memcpy(&patl->pat, pat, sizeof(*pat));
--
2.0.4

+ 38
- 0
net/haproxy/patches/0002-BUG-MEDIUM-pattern-some-entries-are-not-deleted-with.patch View File

@ -0,0 +1,38 @@
From 623401b983185c1e0f6507e96557de3bc46fd41b Mon Sep 17 00:00:00 2001
From: Thierry FOURNIER <tfournier@exceliance.fr>
Date: Fri, 6 Feb 2015 17:53:54 +0100
Subject: [PATCH 2/2] BUG/MEDIUM: pattern: some entries are not deleted with
case insensitive match
ACL or map entries are not deleted with the command "del acl" or "del map"
if the case insentive flag is set.
This is because the the case insensitive string are stored in a list and the
default delete function associated with string looks in a tree. I add a check
of the case insensitive flag and execute the delete function for lists if it
is set.
This patch must be backported in 1.5 version.
(cherry picked from commit 73bc285be194f443dc7eab9c949e87e1dbe8f70c)
---
src/pattern.c | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/src/pattern.c b/src/pattern.c
index a6fc52d..b19ffe2 100644
--- a/src/pattern.c
+++ b/src/pattern.c
@@ -1308,6 +1308,10 @@ void pat_del_tree_str(struct pattern_expr *expr, struct pat_ref_elt *ref)
struct ebmb_node *node, *next_node;
struct pattern_tree *elt;
+ /* If the flag PAT_F_IGNORE_CASE is set, we cannot use trees */
+ if (expr->mflags & PAT_MF_IGNORE_CASE)
+ return pat_del_list_ptr(expr, ref);
+
/* browse each node of the tree. */
for (node = ebmb_first(&expr->pattern_tree), next_node = node ? ebmb_next(node) : NULL;
node;
--
2.0.4

Loading…
Cancel
Save