Browse Source
Merge pull request #13272 from neheb/ught
libuhttpd: fix compilation with uClibc-ng
lilik-openwrt-22.03
Rosen Penev
4 years ago
committed by
GitHub
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with
11 additions and
1 deletions
-
libs/libuhttpd/Makefile
-
libs/libuhttpd/patches/010-offset.patch
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=libuhttpd |
|
|
|
PKG_VERSION:=3.2.0 |
|
|
|
PKG_RELEASE:=1 |
|
|
|
PKG_RELEASE:=2 |
|
|
|
|
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz |
|
|
|
PKG_SOURCE_URL=https://github.com/zhaojh329/libuhttpd/releases/download/v$(PKG_VERSION) |
|
|
|
|
|
@ -0,0 +1,10 @@ |
|
|
|
--- a/src/file.c
|
|
|
|
+++ b/src/file.c
|
|
|
|
@@ -24,6 +24,7 @@
|
|
|
|
|
|
|
|
#define _DEFAULT_SOURCE |
|
|
|
#define _XOPEN_SOURCE |
|
|
|
+#define _FILE_OFFSET_BITS 64
|
|
|
|
|
|
|
|
#include <stdio.h> |
|
|
|
#include <stdlib.h> |