Browse Source

Merge pull request #8368 from neheb/p

python: Refresh patches
lilik-openwrt-22.03
Hannu Nyman 5 years ago
committed by GitHub
parent
commit
840d05eb8e
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
4 changed files with 7 additions and 11 deletions
  1. +1
    -1
      lang/python/python/patches/001-enable-zlib.patch
  2. +3
    -3
      lang/python/python/patches/005-fix-bluetooth-support.patch
  3. +2
    -4
      lang/python/python/patches/011-fix-ssl-build-use-have-npn.patch
  4. +1
    -3
      lang/python/python/patches/017_lib2to3_fix_pyc_search.patch

+ 1
- 1
lang/python/python/patches/001-enable-zlib.patch View File

@ -17,4 +17,4 @@ Subject: [PATCH] enable zlib
+zlib zlibmodule.c -lz
# Interface to the Expat XML parser
#
# More information on Expat can be found at www.libexpat.org.

+ 3
- 3
lang/python/python/patches/005-fix-bluetooth-support.patch View File

@ -1,6 +1,6 @@
--- a/configure
+++ b/configure
@@ -7077,7 +7077,7 @@ sys/param.h sys/poll.h sys/random.h sys/
@@ -7084,7 +7084,7 @@ sys/param.h sys/poll.h sys/random.h sys/
sys/termio.h sys/time.h \
sys/times.h sys/types.h sys/un.h sys/utsname.h sys/wait.h pty.h libutil.h \
sys/resource.h netpacket/packet.h sysexits.h bluetooth.h \
@ -9,7 +9,7 @@
do :
as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
ac_fn_c_check_header_mongrel "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default"
@@ -7299,6 +7299,24 @@ fi
@@ -7306,6 +7306,24 @@ fi
fi
@ -36,7 +36,7 @@
do :
--- a/configure.ac
+++ b/configure.ac
@@ -1732,10 +1732,17 @@ sys/param.h sys/poll.h sys/random.h sys/
@@ -1739,10 +1739,17 @@ sys/param.h sys/poll.h sys/random.h sys/
sys/termio.h sys/time.h \
sys/times.h sys/types.h sys/un.h sys/utsname.h sys/wait.h pty.h libutil.h \
sys/resource.h netpacket/packet.h sysexits.h bluetooth.h \


+ 2
- 4
lang/python/python/patches/011-fix-ssl-build-use-have-npn.patch View File

@ -1,8 +1,6 @@
diff --git a/Modules/_ssl.c b/Modules/_ssl.c
index a96c419260..c80437eef7 100644
--- a/Modules/_ssl.c
+++ b/Modules/_ssl.c
@@ -1586,7 +1586,7 @@ static PyObject *PySSL_version(PySSLSocket *self)
@@ -1590,7 +1590,7 @@ static PyObject *PySSL_version(PySSLSocket *self)
return PyUnicode_FromString(version);
}
@ -11,7 +9,7 @@ index a96c419260..c80437eef7 100644
static PyObject *PySSL_selected_npn_protocol(PySSLSocket *self) {
const unsigned char *out;
unsigned int outlen;
@@ -2114,7 +2114,7 @@ static PyMethodDef PySSLMethods[] = {
@@ -2118,7 +2118,7 @@ static PyMethodDef PySSLMethods[] = {
PySSL_peercert_doc},
{"cipher", (PyCFunction)PySSL_cipher, METH_NOARGS},
{"version", (PyCFunction)PySSL_version, METH_NOARGS},


+ 1
- 3
lang/python/python/patches/017_lib2to3_fix_pyc_search.patch View File

@ -1,8 +1,6 @@
diff --git a/Lib/lib2to3/refactor.py b/Lib/lib2to3/refactor.py
index 7841b99..1e0d3b3 100644
--- a/Lib/lib2to3/refactor.py
+++ b/Lib/lib2to3/refactor.py
@@ -37,6 +37,12 @@ def get_all_fix_names(fixer_pkg, remove_prefix=True):
@@ -40,6 +40,12 @@ def get_all_fix_names(fixer_pkg, remove_prefix=True):
if remove_prefix:
name = name[4:]
fix_names.append(name[:-3])


Loading…
Cancel
Save