Browse Source

poco: Changed poco version to all, and from minimal build to typical.

Signed-off-by: Jakub Jalowiczor <jaluwka@gmail.com>
lilik-openwrt-22.03
Jakub Jalowiczor 5 years ago
parent
commit
83c21577a4
3 changed files with 17 additions and 21 deletions
  1. +5
    -6
      libs/poco/Makefile
  2. +8
    -12
      libs/poco/patches/100-configure.patch
  3. +4
    -3
      libs/poco/patches/200-strerror.patch

+ 5
- 6
libs/poco/Makefile View File

@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=poco
PKG_VERSION:=1.9.0
PKG_VERSION:=1.9.0-all
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://pocoproject.org/releases/$(PKG_NAME)-$(PKG_VERSION)
PKG_HASH:=a0a5a03d87c585f1a43def33bfc52c0c34a528e43a7b13bc83841a7c00adde39
PKG_HASH:=b6e33898588e74337efec4e8d8b9b277bb653b08318a79215f9aa4a3ff1ea9fd
PKG_LICENSE:=BSL-1.0
PKG_LICENSE_FILES:=LICENSE
@ -47,13 +47,12 @@ CONFIGURE_ARGS += \
--no-fpenvironment \
--no-sharedmemory \
--no-wstring \
--poquito \
--minimal \
--typical \
--shared
define Package/poco/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libPoco{Foundation,XML,JSON,Net,Util}.so* $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libPoco{Foundation,XML,JSON,Net,Util,Crypto,NetSSL,Encodings}.so* $(1)/usr/lib/
endef
define Build/InstallDev
@ -61,7 +60,7 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/include/Poco $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libPoco{Foundation,XML,JSON,Net,Util}.so* $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libPoco{Foundation,XML,JSON,Net,Util,Crypto,NetSSL,Encodings}.so* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,poco))

+ 8
- 12
libs/poco/patches/100-configure.patch View File

@ -1,15 +1,11 @@
--- a/configure
+++ b/configure
@@ -237,9 +237,9 @@ while [ $# -ge 1 ]; do
;;
@@ -238,6 +238,6 @@
*)
- showhelp
- exit 1
- ;;
+# showhelp
+# exit 1
+# ;;
esac
shift
*)
- showhelp
- exit 1
+# showhelp
+# exit 1
;;
esac

+ 4
- 3
libs/poco/patches/200-strerror.patch View File

@ -3,9 +3,10 @@
@@ -70,7 +70,7 @@ namespace Poco {
#if (_XOPEN_SOURCE >= 600) || POCO_OS == POCO_OS_ANDROID || __APPLE__
setMessage(strerror_r(err, _buffer, sizeof(_buffer)));
setMessage(strerror_r(err, _buffer, sizeof(_buffer)));
-#elif _GNU_SOURCE
+#elif (_GNU_SOURCE && (defined __GLIBC__ || defined __UCLIBC__))
setMessage(strerror_r(err, _buffer, sizeof(_buffer)));
setMessage(strerror_r(err, _buffer, sizeof(_buffer)));
#else
setMessage(strerror(err));
setMessage(strerror(err));

Loading…
Cancel
Save