Browse Source

python-cryptography: bump to version 2.2.2

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lilik-openwrt-22.03
Alexandru Ardelean 7 years ago
parent
commit
81894aa414
2 changed files with 9 additions and 5 deletions
  1. +4
    -4
      lang/python/python-cryptography/Makefile
  2. +5
    -1
      lang/python/python-cryptography/patches/002-remove-undefined-dtls-methods.patch

+ 4
- 4
lang/python/python-cryptography/Makefile View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=python-cryptography PKG_NAME:=python-cryptography
PKG_VERSION:=2.1.4
PKG_RELEASE:=2
PKG_VERSION:=2.2.2
PKG_RELEASE:=1
PKG_SOURCE:=cryptography-$(PKG_VERSION).tar.gz PKG_SOURCE:=cryptography-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://pypi.python.org/packages/78/c5/7188f15a92413096c93053d5304718e1f6ba88b818357d05d19250ebff85
PKG_HASH:=e4d967371c5b6b2e67855066471d844c5d52d210c36c28d49a8507b96e2c5291
PKG_SOURCE_URL:=https://pypi.io/packages/source/c/cryptography
PKG_HASH:=9fc295bf69130a342e7a19a39d7bbeb15c0bcaabc7382ec33ef3b2b7d18d2f63
PKG_LICENSE:=Apache-2.0 BSD-3-Clause PKG_LICENSE:=Apache-2.0 BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE.APACHE LICENSE.BSD PKG_LICENSE_FILES:=LICENSE.APACHE LICENSE.BSD


+ 5
- 1
lang/python/python-cryptography/patches/002-remove-undefined-dtls-methods.patch View File

@ -1,12 +1,16 @@
--- a/src/_cffi_src/openssl/ssl.py --- a/src/_cffi_src/openssl/ssl.py
+++ b/src/_cffi_src/openssl/ssl.py +++ b/src/_cffi_src/openssl/ssl.py
@@ -597,9 +597,6 @@ static const long TLS_ST_OK = 0;
@@ -646,13 +646,6 @@ static const long TLS_ST_OK = 0;
#if defined(OPENSSL_NO_DTLS) || CRYPTOGRAPHY_OPENSSL_LESS_THAN_102 #if defined(OPENSSL_NO_DTLS) || CRYPTOGRAPHY_OPENSSL_LESS_THAN_102
static const long Cryptography_HAS_GENERIC_DTLS_METHOD = 0; static const long Cryptography_HAS_GENERIC_DTLS_METHOD = 0;
-const SSL_METHOD *(*DTLS_method)(void) = NULL; -const SSL_METHOD *(*DTLS_method)(void) = NULL;
-const SSL_METHOD *(*DTLS_server_method)(void) = NULL; -const SSL_METHOD *(*DTLS_server_method)(void) = NULL;
-const SSL_METHOD *(*DTLS_client_method)(void) = NULL; -const SSL_METHOD *(*DTLS_client_method)(void) = NULL;
-static const long SSL_OP_NO_DTLSv1 = NULL;
-static const long SSL_OP_NO_DTLSv1_2 = NULL;
-long *(*DTLS_set_link_mtu)(SSL *, long) = NULL;
-long *(*DTLS_get_link_min_mtu)(SSL *) = NULL;
#else #else
static const long Cryptography_HAS_GENERIC_DTLS_METHOD = 1; static const long Cryptography_HAS_GENERIC_DTLS_METHOD = 1;
#endif #endif

Loading…
Cancel
Save