Browse Source
ptunnel-ng: fix compilation with kernel 5.15
Some header change requires to include musl's headers first.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry picked from commit 468863128f
)
lilik-openwrt-22.03
Rosen Penev
3 years ago
committed by
Josef Schlehofer
No known key found for this signature in database
GPG Key ID: B950216FE4329F4C
2 changed files with
23 additions and
1 deletions
-
net/ptunnel-ng/Makefile
-
net/ptunnel-ng/patches/010-musl.patch
|
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=ptunnel-ng |
|
|
|
PKG_VERSION:=1.42 |
|
|
|
PKG_RELEASE:=1 |
|
|
|
PKG_RELEASE:=2 |
|
|
|
|
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz |
|
|
|
PKG_SOURCE_URL:=https://codeload.github.com/lnslbrty/ptunnel-ng/tar.gz/v$(PKG_VERSION)? |
|
|
|
|
|
@ -0,0 +1,22 @@ |
|
|
|
--- a/src/ptunnel.h
|
|
|
|
+++ b/src/ptunnel.h
|
|
|
|
@@ -45,9 +45,6 @@
|
|
|
|
#define PING_TUNNEL_H 1 |
|
|
|
|
|
|
|
#ifndef WIN32 |
|
|
|
-#ifdef HAVE_ICMPFILTER
|
|
|
|
-#include <linux/icmp.h>
|
|
|
|
-#endif
|
|
|
|
#ifdef HAVE_SYS_UNISTD_H |
|
|
|
#include <sys/unistd.h> |
|
|
|
#endif |
|
|
|
@@ -56,6 +53,9 @@
|
|
|
|
#include <netinet/in.h> |
|
|
|
#include <arpa/inet.h> |
|
|
|
#include <netdb.h> |
|
|
|
+#ifdef HAVE_ICMPFILTER
|
|
|
|
+#include <linux/icmp.h>
|
|
|
|
+#endif
|
|
|
|
#include <pthread.h> |
|
|
|
#include <errno.h> |
|
|
|
#include <net/ethernet.h> |