Browse Source

ruby: remove minitest deps on gems

minitest can live without gems. Just a minor fix to
solve a require that fails when gem is missing

Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
lilik-openwrt-22.03
Luiz Angelo Daros de Luca 10 years ago
parent
commit
7fda1869e3
2 changed files with 14 additions and 1 deletions
  1. +1
    -1
      lang/ruby/Makefile
  2. +13
    -0
      lang/ruby/patches/002-minitest-remove_gems_dep.patch

+ 1
- 1
lang/ruby/Makefile View File

@ -16,7 +16,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ruby
PKG_VERSION:=2.1.2
PKG_RELEASE:=5
PKG_RELEASE:=6
PKG_LIBVER:=2.1


+ 13
- 0
lang/ruby/patches/002-minitest-remove_gems_dep.patch View File

@ -0,0 +1,13 @@
--- ruby-2.1.2.orig/lib/minitest/autorun.rb 2014-09-03 02:22:29.769909573 -0300
+++ ruby-2.1.2/lib/minitest/autorun.rb 2014-09-03 02:22:29.768909580 -0300
@@ -6,8 +6,9 @@
######################################################################
begin
- require 'rubygems'
gem 'minitest'
+rescue NameError => e # --disable-gems
+ raise unless e.name == :gem
rescue Gem::LoadError
# do nothing
end

Loading…
Cancel
Save