Browse Source

libwebsockets: fix compilation with newer GCC

Errors on uninitialized variable. No idea why only on powerpc64.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 2 years ago
parent
commit
7d1a019734
2 changed files with 24 additions and 1 deletions
  1. +1
    -1
      libs/libwebsockets/Makefile
  2. +23
    -0
      libs/libwebsockets/patches/010-uninit.patch

+ 1
- 1
libs/libwebsockets/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libwebsockets
PKG_VERSION:=4.2.1
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)


+ 23
- 0
libs/libwebsockets/patches/010-uninit.patch View File

@ -0,0 +1,23 @@
From 1f9925b44379941065690f0dce8ca0c79414b9f1 Mon Sep 17 00:00:00 2001
From: Rosen Penev <rosenp@gmail.com>
Date: Tue, 1 Feb 2022 09:13:11 +0000
Subject: [PATCH] genec: show correct nid when not allowed
As noticed by gcc11 warning
https://github.com/warmcat/libwebsockets/pull/2551
---
lib/tls/lws-genec-common.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- a/lib/tls/lws-genec-common.c
+++ b/lib/tls/lws-genec-common.c
@@ -94,7 +94,7 @@ lws_genec_confirm_curve_allowed_by_tls_i
}
} while (e > 0);
- lwsl_err("%s: unsupported curve group nid %d\n", __func__, n);
+ lwsl_err("%s: unsupported curve group nid %d\n", __func__, id);
return -1;
}

Loading…
Cancel
Save