Signed-off-by: Steven Barth <steven@midlink.org>lilik-openwrt-22.03
@ -1,10 +1,10 @@ | |||||
--- a/configure.in | --- a/configure.in | ||||
+++ b/configure.in | +++ b/configure.in | ||||
@@ -195,7 +195,6 @@ AC_DEFINE_UNQUOTED(PASSWD_PROGRAM, "$sha | |||||
dnl XXX - quick hack, should disappear before anyone notices :). | |||||
@@ -197,7 +197,6 @@ dnl XXX - quick hack, should disappear b | |||||
AC_DEFINE(USE_SYSLOG, 1, [Define to use syslog().]) | AC_DEFINE(USE_SYSLOG, 1, [Define to use syslog().]) | ||||
AC_DEFINE(RLOGIN, 1, [Define if login should support the -r flag for rlogind.]) | |||||
-AC_DEFINE(RUSEROK, 0, [Define to the ruserok() "success" return value (0 or 1).]) | |||||
if test "$ac_cv_func_ruserok" = "yes"; then | |||||
AC_DEFINE(RLOGIN, 1, [Define if login should support the -r flag for rlogind.]) | |||||
- AC_DEFINE(RUSEROK, 0, [Define to the ruserok() "success" return value (0 or 1).]) | |||||
fi | |||||
AC_ARG_ENABLE(shadowgrp, | AC_ARG_ENABLE(shadowgrp, | ||||
[AC_HELP_STRING([--enable-shadowgrp], [enable shadow group support @<:@default=yes@:>@])], |
@ -0,0 +1,32 @@ | |||||
--- a/src/usermod.c | |||||
+++ b/src/usermod.c | |||||
@@ -1361,6 +1361,7 @@ static void process_flags (int argc, cha | |||||
exit (E_UID_IN_USE); | |||||
} | |||||
+#ifdef ENABLE_SUBIDS | |||||
if ( (vflg || Vflg) | |||||
&& !is_sub_uid) { | |||||
fprintf (stderr, | |||||
@@ -1376,6 +1377,7 @@ static void process_flags (int argc, cha | |||||
Prog, sub_gid_dbname (), "-w", "-W"); | |||||
exit (E_USAGE); | |||||
} | |||||
+#endif | |||||
} | |||||
/* | |||||
--- a/src/Makefile.am | |||||
+++ b/src/Makefile.am | |||||
@@ -52,7 +52,10 @@ usbin_PROGRAMS = \ | |||||
noinst_PROGRAMS = id sulogin | |||||
suidbins = su | |||||
-suidubins = chage chfn chsh expiry gpasswd newgrp passwd newuidmap newgidmap | |||||
+suidubins = chage chfn chsh expiry gpasswd newgrp passwd | |||||
+if ENABLE_SUBIDS | |||||
+ suidubins += newuidmap newgidmap | |||||
+endif | |||||
if ACCT_TOOLS_SETUID | |||||
suidubins += chage chgpasswd chpasswd groupadd groupdel groupmod newusers useradd userdel usermod | |||||
endif |