Browse Source

php5: gd: do not link against libiconv (fixes #706)

This commit adds a patch to enforce the usage of an alternative
code path, preventing the need of libiconv in the bundled libgd
of php.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
lilik-openwrt-22.03
Michael Heimpold 10 years ago
parent
commit
7c4ed7731c
2 changed files with 15 additions and 1 deletions
  1. +1
    -1
      lang/php5/Makefile
  2. +14
    -0
      lang/php5/patches/800-gd-iconv.patch

+ 1
- 1
lang/php5/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=php
PKG_VERSION:=5.4.36
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>


+ 14
- 0
lang/php5/patches/800-gd-iconv.patch View File

@ -0,0 +1,14 @@
--- a/ext/gd/libgd/gdkanji.c
+++ b/ext/gd/libgd/gdkanji.c
@@ -9,6 +9,11 @@
#include "gdhelpers.h"
#include <stdarg.h>
+
+/* force usage of internal conversation routine */
+#undef HAVE_ICONV_H
+#undef HAVE_ICONV
+
#if defined(HAVE_ICONV_H) || defined(HAVE_ICONV)
#include <iconv.h>
#ifdef HAVE_ERRNO_H

Loading…
Cancel
Save