|
|
@ -15,10 +15,10 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> |
|
|
|
Makefile.in | 10 ++-------- |
|
|
|
1 file changed, 2 insertions(+), 8 deletions(-) |
|
|
|
|
|
|
|
Index: apr-1.5.1/Makefile.in
|
|
|
|
Index: apr-1.5.2/Makefile.in
|
|
|
|
===================================================================
|
|
|
|
--- apr-1.5.1.orig/Makefile.in
|
|
|
|
+++ apr-1.5.1/Makefile.in
|
|
|
|
--- apr-1.5.2.orig/Makefile.in
|
|
|
|
+++ apr-1.5.2/Makefile.in
|
|
|
|
@@ -20,7 +20,7 @@ INCDIR=./include
|
|
|
|
OSDIR=$(top_srcdir)/include/arch/@OSDIR@ |
|
|
|
DEFOSDIR=$(INCDIR)/arch/@DEFAULT_OSDIR@ |
|
|
@ -36,19 +36,16 @@ Index: apr-1.5.1/Makefile.in |
|
|
|
include/private/apr_escape_test_char.h |
|
|
|
DISTCLEAN_TARGETS = config.cache config.log config.status \ |
|
|
|
include/apr.h include/arch/unix/apr_private.h \ |
|
|
|
@@ -130,13 +129,8 @@ check: $(TARGET_LIB)
|
|
|
|
etags: |
|
|
|
etags `find . -name '*.[ch]'` |
|
|
|
@@ -135,9 +134,9 @@ tools/gen_test_char.lo: tools/gen_test_c
|
|
|
|
$(APR_MKDIR) tools |
|
|
|
$(LT_COMPILE) |
|
|
|
|
|
|
|
-make_tools_dir:
|
|
|
|
- $(APR_MKDIR) tools
|
|
|
|
-
|
|
|
|
-OBJECTS_gen_test_char = tools/gen_test_char.lo $(LOCAL_LIBS)
|
|
|
|
-tools/gen_test_char.lo: make_tools_dir
|
|
|
|
-tools/gen_test_char@EXEEXT@: $(OBJECTS_gen_test_char)
|
|
|
|
- $(LINK_PROG) $(OBJECTS_gen_test_char) $(ALL_LIBS)
|
|
|
|
-
|
|
|
|
+tools/gen_test_char@EXEEXT@: tools/gen_test_char.c
|
|
|
|
+ $(BUILDCC) $(CFLAGS_FOR_BUILD) $< -o $@
|
|
|
|
|
|
|
|
+
|
|
|
|
include/private/apr_escape_test_char.h: tools/gen_test_char@EXEEXT@ |
|
|
|
$(APR_MKDIR) include/private |
|
|
|
tools/gen_test_char@EXEEXT@ > $@ |