Browse Source

zmq: Make 2 variants, refresh patches, fix C++ build issues

Signed-off-by: Ted Hess <thess@kitschensync.net>
lilik-openwrt-22.03
Ted Hess 9 years ago
parent
commit
79a63ec038
5 changed files with 125 additions and 33 deletions
  1. +27
    -19
      libs/zmq/Makefile
  2. +3
    -3
      libs/zmq/patches/010-disable_pedantic_on_linux_with_ulibc++.patch
  3. +9
    -9
      libs/zmq/patches/020-map_with_const_string_with_ublic++.patch
  4. +2
    -2
      libs/zmq/patches/030-streamoff_missing_with_ulibc++.patch
  5. +84
    -0
      libs/zmq/patches/100-fix-cxx-include-order.patch

+ 27
- 19
libs/zmq/Makefile View File

@ -18,9 +18,9 @@ PKG_LICENSE_FILES:=LICENCE.txt
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:= http://download.zeromq.org
PKG_MD5SUM:=73c39f5eb01b9d7eaf74a5d899f1d03d
PKG_MD5SUM:=0a4b44aa085644f25c177f79dc13f253
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_BUILD_DEPENDS:=libuuid
PKG_FIXUP:=autoreconf
@ -31,26 +31,34 @@ PKG_INSTALL:=1
include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
define Package/libzmq
define Package/libzmq/default
TITLE:=ZeroMQ - Message Queue engine
URL:=http://www.zeromq.org/
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=+libuuid +libpthread +librt +PACKAGE_libsodium:libsodium $(CXX_DEPENDS)
MENU:=1
DEPENDS:=+libuuid +libpthread +librt $(CXX_DEPENDS)
PROVIDES:=libzmq
endef
define Package/libzmq/config
config LIBZMQ_CURVEZMQ
bool "Include support for CurveZMQ security"
depends on PACKAGE_libzmq
default y
select PACKAGE_libsodium
define Package/libzmq-nc
$(call Package/libzmq/default)
VARIANT:=nc
endef
define Package/libzmq/description
define Package/libzmq-curve
$(call Package/libzmq/default)
VARIANT:=curve
TITLE+= (CurveZMQ)
DEPENDS+=+libsodium
endef
define Package/libzmq-nc/description
This package contains the ZeroMQ messaging engine shared library.
CurveZMQ security protocols are optional using libsodium.
endef
define Package/libzmq-curve/description
$(call Package/libzmq-nc/description)
Includes CurveZMQ security by libsodium.
endef
# add extra configure flags here
@ -58,15 +66,12 @@ CONFIGURE_ARGS += \
--enable-static \
--enable-shared
ifneq ($(CONFIG_PACKAGE_libsodium),)
ifeq ($(BUILD_VARIANT),curve)
CONFIGURE_ARGS+= --with-libsodium
else
CONFIGURE_ARGS+= --without-libsodium
endif
# add make variable overrides here
MAKE_FLAGS +=
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/zmq.h $(1)/usr/include
@ -77,9 +82,12 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libzmq.pc $(1)/usr/lib/pkgconfig/
endef
define Package/libzmq/install
define Package/libzmq-nc/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libzmq.so.* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,libzmq))
Package/libzmq-curve/install=$(Package/libzmq-nc/install)
$(eval $(call BuildPackage,libzmq-nc))
$(eval $(call BuildPackage,libzmq-curve))

libs/zmq/patches/disable_pedantic_on_linux_with_ulibc++.patch → libs/zmq/patches/010-disable_pedantic_on_linux_with_ulibc++.patch View File


libs/zmq/patches/map_with_const_string_with_ublic++.patch → libs/zmq/patches/020-map_with_const_string_with_ublic++.patch View File


libs/zmq/patches/streamoff_missing_with_ulibc++.patch → libs/zmq/patches/030-streamoff_missing_with_ulibc++.patch View File


+ 84
- 0
libs/zmq/patches/100-fix-cxx-include-order.patch View File

@ -0,0 +1,84 @@
--- a/src/mtrie.cpp
+++ b/src/mtrie.cpp
@@ -17,11 +17,11 @@
along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
-#include <stdlib.h>
-
#include <new>
#include <algorithm>
+#include <stdlib.h>
+
#include "platform.hpp"
#if defined ZMQ_HAVE_WINDOWS
#include "windows.hpp"
--- a/src/raw_encoder.cpp
+++ b/src/raw_encoder.cpp
@@ -17,6 +17,11 @@
along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
+#include <basic_definitions>
+#include <exception>
+#include <cstddef>
+#include <algorithm>
+
#include "encoder.hpp"
#include "raw_encoder.hpp"
#include "likely.hpp"
--- a/src/trie.cpp
+++ b/src/trie.cpp
@@ -17,11 +17,11 @@
along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
-#include <stdlib.h>
-
#include <new>
#include <algorithm>
+#include <stdlib.h>
+
#include "platform.hpp"
#if defined ZMQ_HAVE_WINDOWS
#include "windows.hpp"
--- a/src/encoder.hpp
+++ b/src/encoder.hpp
@@ -29,7 +29,6 @@
#include <stddef.h>
#include <string.h>
#include <stdlib.h>
-#include <algorithm>
#include "err.hpp"
#include "msg.hpp"
--- a/src/v1_encoder.cpp
+++ b/src/v1_encoder.cpp
@@ -17,6 +17,11 @@
along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
+#include <basic_definitions>
+#include <exception>
+#include <cstddef>
+#include <algorithm>
+
#include "encoder.hpp"
#include "v1_encoder.hpp"
#include "likely.hpp"
--- a/src/v2_encoder.cpp
+++ b/src/v2_encoder.cpp
@@ -17,6 +17,11 @@
along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
+#include <basic_definitions>
+#include <exception>
+#include <cstddef>
+#include <algorithm>
+
#include "v2_protocol.hpp"
#include "v2_encoder.hpp"
#include "likely.hpp"

Loading…
Cancel
Save