Browse Source

Merge pull request #6405 from TDT-AG/pr/20180704-strongswan-add-openwrt-hotplug

strongswan: add hotplug script user handling
lilik-openwrt-22.03
Stijn Tintel 6 years ago
committed by GitHub
parent
commit
78e3c2b1a9
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
4 changed files with 26 additions and 18 deletions
  1. +3
    -1
      net/strongswan/Makefile
  2. +7
    -0
      net/strongswan/files/etc/hotplug.d/ipsec/01-user
  3. +16
    -0
      net/strongswan/patches/300-include-ipsec-hotplug.patch
  4. +0
    -17
      net/strongswan/patches/300-include-ipsec-user-script.patch

+ 3
- 1
net/strongswan/Makefile View File

@ -561,7 +561,9 @@ define Plugin/updown/install
$(INSTALL_DIR) $(1)/usr/lib/ipsec/plugins
$(CP) $(PKG_INSTALL_DIR)/usr/lib/ipsec/_updown $(1)/usr/lib/ipsec/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/ipsec/plugins/libstrongswan-updown.so $(1)/usr/lib/ipsec/plugins/
$(INSTALL_DIR) $(1)/etc
$(INSTALL_DIR) $(1)/etc/hotplug.d/ipsec
$(CP) ./files/etc/hotplug.d/ipsec/01-user \
$(1)/etc/hotplug.d/ipsec/01-user
endef
define Plugin/vici/install


+ 7
- 0
net/strongswan/files/etc/hotplug.d/ipsec/01-user View File

@ -0,0 +1,7 @@
#!/bin/sh
[ -e "/etc/ipsec.user" ] && {
. /etc/ipsec.user "$2"
}
exit 0

+ 16
- 0
net/strongswan/patches/300-include-ipsec-hotplug.patch View File

@ -0,0 +1,16 @@
--- a/src/_updown/_updown.in
+++ b/src/_updown/_updown.in
@@ -22,6 +22,13 @@
# that, and use the (left/right)updown parameters in ipsec.conf to make
# strongSwan use yours instead of this default one.
+# Add your custom commands to the file "/etc/ipsec.user". Other packages could
+# also install their scripts in the directory "/etc/hotplug.d/ipsec".
+# This files/scripts are executed by the openwrt hotplug functionality on
+# ipsec events.
+
+exec /sbin/hotplug-call ipsec "$1"
+
# PLUTO_VERSION
# indicates what version of this interface is being
# used. This document describes version 1.1. This

+ 0
- 17
net/strongswan/patches/300-include-ipsec-user-script.patch View File

@ -1,17 +0,0 @@
--- a/src/_updown/_updown.in
+++ b/src/_updown/_updown.in
@@ -16,11 +16,9 @@
# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
# for more details.
-# CAUTION: Installing a new version of strongSwan will install a new
-# copy of this script, wiping out any custom changes you make. If
-# you need changes, make a copy of this under another name, and customize
-# that, and use the (left/right)updown parameters in ipsec.conf to make
-# strongSwan use yours instead of this default one.
+# Add your custom ip rules to the /etc/ipsec.user file if you need that functionality.
+
+[ -e /etc/ipsec.user ] && . /etc/ipsec.user "$1"
# PLUTO_VERSION
# indicates what version of this interface is being

Loading…
Cancel
Save