Browse Source

haproxy: Update HAProxy to v2.2.1

- New major version (LTS release)
- Update haproxy download URL and hash
- Remove obsolete dladdr1-dependency-patch as it has been upstreamed
- USE_REGPARM is obsolete and therefore removed from our Makefile

Signed-off-by: Christian Lachner <gladiac@gmail.com>
lilik-openwrt-22.03
Christian Lachner 4 years ago
parent
commit
78d99efb9b
3 changed files with 5 additions and 37 deletions
  1. +3
    -12
      net/haproxy/Makefile
  2. +2
    -2
      net/haproxy/get-latest-patches.sh
  3. +0
    -23
      net/haproxy/patches/000-OPENWRT-BUILD-make-dladdr1-depend-on-glibc-version-and-not-__USE_GNU.patch

+ 3
- 12
net/haproxy/Makefile View File

@ -10,12 +10,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=haproxy
PKG_VERSION:=2.1.7
PKG_VERSION:=2.2.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.haproxy.org/download/2.1/src
PKG_HASH:=392e6cf18e75fe7e166102e8c4512942890a0b5ae738f6064faab4687f60a339
PKG_SOURCE_URL:=https://www.haproxy.org/download/2.2/src
PKG_HASH:=536552af1316807c01de727ad3dac84b3a2f5285db32e9bfdfe234e47ff9d124
PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>, \
Christian Lachner <gladiac@gmail.com>
@ -79,11 +79,6 @@ $(call Package/haproxy/Default/description)
endef
ENABLE_LUA:=y
ENABLE_REGPARM:=n
ifeq ($(CONFIG_TARGET_x86),y)
ENABLE_REGPARM:=y
endif
ifeq ($(CONFIG_USE_UCLIBC),y)
ADDON+=USE_LIBCRYPT=
@ -94,10 +89,6 @@ ifeq ($(BUILD_VARIANT),ssl)
ADDON+=ADDLIB="-lcrypto -lm"
endif
ifeq ($(ENABLE_REGPARM),y)
ADDON+=USE_REGPARM=1
endif
define Build/Compile
$(MAKE) TARGET=linux-glibc -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \


+ 2
- 2
net/haproxy/get-latest-patches.sh View File

@ -1,7 +1,7 @@
#!/bin/sh
CLONEURL=https://git.haproxy.org/git/haproxy-2.1.git
BASE_TAG=v2.1.7
CLONEURL=https://git.haproxy.org/git/haproxy-2.2.git
BASE_TAG=v2.2.1
TMP_REPODIR=tmprepo
PATCHESDIR=patches


+ 0
- 23
net/haproxy/patches/000-OPENWRT-BUILD-make-dladdr1-depend-on-glibc-version-and-not-__USE_GNU.patch View File

@ -1,23 +0,0 @@
commit 62af9c83f9ed2b25e0061798e29e3cccfce5fbdc
Author: Willy Tarreau <w@1wt.eu>
Date: Tue Mar 10 07:51:48 2020 +0100
BUILD: make dladdr1 depend on glibc version and not __USE_GNU
Technically speaking the call was implemented in glibc 2.3 so we must
rely on this and not on __USE_GNU which is an internal define of glibc
to track use of GNU_SOURCE.
diff --git a/src/standard.c b/src/standard.c
index e0ea8328e..d16eebfea 100644
--- a/src/standard.c
+++ b/src/standard.c
@@ -4350,7 +4350,7 @@ void debug_hexdump(FILE *out, const char *pfx, const char *buf,
static int dladdr_and_size(const void *addr, Dl_info *dli, size_t *size)
{
int ret;
-#ifdef __USE_GNU // most detailed one
+#if (__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 3)) // most detailed one
const ElfW(Sym) *sym;
ret = dladdr1(addr, dli, (void **)&sym, RTLD_DL_SYMENT);

Loading…
Cancel
Save