Browse Source

Merge pull request #8579 from neheb/znc2

znc: Update deprecated API patch
lilik-openwrt-22.03
Jonas Gorski 6 years ago
committed by GitHub
parent
commit
783f3e4ace
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 20 additions and 5 deletions
  1. +1
    -1
      net/znc/Makefile
  2. +19
    -4
      net/znc/patches/120-openssl-deprecated.patch

+ 1
- 1
net/znc/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=znc
PKG_VERSION:=1.7.3
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://znc.in/releases \


+ 19
- 4
net/znc/patches/120-openssl-deprecated.patch View File

@ -1,3 +1,14 @@
--- a/src/Utils.cpp
+++ b/src/Utils.cpp
@@ -29,7 +29,7 @@
#include <openssl/ssl.h>
#include <openssl/bn.h>
#include <openssl/rsa.h>
-#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || (LIBRESSL_VERSION_NUMBER < 0x20700000L)
+#if (OPENSSL_VERSION_NUMBER < 0x10100000L)
#define X509_getm_notBefore X509_get_notBefore
#define X509_getm_notAfter X509_get_notAfter
#endif
--- a/third_party/Csocket/Csocket.cc
+++ b/third_party/Csocket/Csocket.cc
@@ -47,10 +47,16 @@
@ -18,11 +29,15 @@
#define HAVE_ERR_REMOVE_STATE
#ifdef OPENSSL_VERSION_NUMBER
# if OPENSSL_VERSION_NUMBER >= 0x10000000
@@ -594,9 +600,11 @@ void ShutdownCsocket()
#ifndef OPENSSL_IS_BORINGSSL
CONF_modules_unload( 1 );
#endif
@@ -583,6 +589,7 @@ bool InitCsocket()
void ShutdownCsocket()
{
#ifdef HAVE_LIBSSL
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
#if defined( HAVE_ERR_REMOVE_THREAD_STATE )
ERR_remove_thread_state( NULL );
#elif defined( HAVE_ERR_REMOVE_STATE )
@@ -597,6 +604,7 @@ void ShutdownCsocket()
ERR_free_strings();
EVP_cleanup();
CRYPTO_cleanup_all_ex_data();


Loading…
Cancel
Save