Browse Source

fontconfig: avoid compilation problem (on Ubuntu)

Partially revert an upstream commit to avoid build breakage
on Ubuntu.

Refrerence to discussion starting at
https://github.com/openwrt/packages/pull/16726#issuecomment-927309052

Upstream commit:
  ae9ac2a1bf
  meson: fix cross-compilation issues with gperf header file preprocessing

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
lilik-openwrt-22.03
Hannu Nyman 3 years ago
committed by Rosen Penev
parent
commit
7778661b08
1 changed files with 26 additions and 0 deletions
  1. +26
    -0
      utils/fontconfig/patches/001-revert-upstream-meson-commit.patch

+ 26
- 0
utils/fontconfig/patches/001-revert-upstream-meson-commit.patch View File

@ -0,0 +1,26 @@
Revert partially the upstream commit ae9ac2a1
Subject: [PATCH] meson: fix cross-compilation issues with gperf header file preprocessing
Pass c_args to the compiler when preprocessing the gperf header file,
they might contain important bits without which compilation/preprocessing
might fail (e.g. with clang on Android). cc.cmd_array() does not include
the c_args and we can't easily look them up from the meson.build file, so
we have to retrieve from the introspection info.
This is basically the Meson equivalent to commit 57103773.
Revert the host_cargs related part of the patch
--- a/src/cutout.py
+++ b/src/cutout.py
@@ -24,7 +24,7 @@ if __name__== '__main__':
break
cpp = args[1]
- ret = subprocess.run(cpp + host_cargs + [args[0].input], stdout=subprocess.PIPE, check=True)
+ ret = subprocess.run(cpp + [args[0].input], stdout=subprocess.PIPE, check=True)
stdout = ret.stdout.decode('utf8')

Loading…
Cancel
Save