Browse Source

sispmctl: fix compilation error with musl

Unpatched compile fails because <sys/types.h> is not included
in <usb.h> (provided by "libusb-compat") and consequently
the 'u_int*_t' types are not found.

This should probably better be fixed in the core "libusb-compat"
package instead.

Signed-off-by: Richard Kunze <richard.kunze@web.de>
lilik-openwrt-22.03
Richard Kunze 10 years ago
parent
commit
773f8d4b13
2 changed files with 26 additions and 0 deletions
  1. +1
    -0
      utils/sispmctl/Makefile
  2. +25
    -0
      utils/sispmctl/patches/001-fix-includes.patch

+ 1
- 0
utils/sispmctl/Makefile View File

@ -43,6 +43,7 @@ define Package/sispmctl/description
multiple SIS-PM devices, too.
endef
TARGET_CFLAGS += -D_GNU_SOURCE
CONFIGURE_ARGS += \
--enable-webless \
--disable-dependency-tracking


+ 25
- 0
utils/sispmctl/patches/001-fix-includes.patch View File

@ -0,0 +1,25 @@
--- a/src/sispm_ctl.c
+++ b/src/sispm_ctl.c
@@ -33,6 +33,7 @@
#include <stdlib.h>
#include <unistd.h>
#include <time.h>
+#include <sys/types.h>
#include <usb.h>
#include <assert.h>
#include "sispm_ctl.h"
--- a/src/main.c
+++ b/src/main.c
@@ -34,11 +34,11 @@
#define __USE_XOPEN
#include <time.h>
#include <signal.h>
-#include <usb.h>
#include <assert.h>
#include <getopt.h>
#include <sys/types.h>
#include <sys/socket.h>
+#include <usb.h>
#include <fcntl.h>

Loading…
Cancel
Save