Browse Source

freeradius3: update to 3.0.18

Signed-off-by: David Yang <mmyangfl@gmail.com>
lilik-openwrt-22.03
David Yang 6 years ago
parent
commit
76b013228d
3 changed files with 9 additions and 31 deletions
  1. +7
    -5
      net/freeradius3/Makefile
  2. +2
    -2
      net/freeradius3/patches/002-disable-session-cache-CVE-2017-9148.patch
  3. +0
    -24
      net/freeradius3/patches/004-tls.c-allow-build-with-no-openssl-engine-support.patch

+ 7
- 5
net/freeradius3/Makefile View File

@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=freeradius3
PKG_VERSION:=release_3_0_17
PKG_RELEASE:=3
PKG_VERSION:=release_3_0_18
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/FreeRADIUS/freeradius-server/archive
PKG_HASH:=5b2382f08c0d9d064298281c1fb8348fc13df76550ce7a5cfc47ea91361fad91
PKG_HASH:=c6802e3ec675b1cf59c850b0f01ed088e2983c5c4daa7f64cc22be4e6ad13ae5
PKG_MAINTAINER:=Lucile Quirion <lucile.quirion@savoirfairelinux.com>
PKG_MAINTAINER:=
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=COPYRIGHT LICENSE
@ -54,7 +54,7 @@ endef
define Package/freeradius3-common
$(call Package/freeradius3/Default)
TITLE:=common files
DEPENDS:=+USE_GLIBC:libpthread +FREERADIUS3_OPENSSL:libopenssl +libcap +libpcap +libncurses +PACKAGE_libpcre:libpcre +libreadline +libtalloc
DEPENDS:=+USE_GLIBC:libpthread +FREERADIUS3_OPENSSL:libopenssl +libcap +libpcap +libncurses +PACKAGE_libpcre:libpcre +libreadline +libtalloc +libatomic
endef
define Package/freeradius3-default
@ -504,6 +504,8 @@ CONFIGURE_ARGS+= \
--without-rlm_unbound \
--without-rlm_yubikey \
CONFIGURE_LIBS+= -latomic
PKG_DICTIONARIES:= \
compat \
freeradius freeradius.internal \


+ 2
- 2
net/freeradius3/patches/002-disable-session-cache-CVE-2017-9148.patch View File

@ -27,7 +27,7 @@ Last-Update: 2017-05-30
return state;
}
@@ -3151,7 +3151,7 @@ post_ca:
@@ -3277,7 +3277,7 @@ post_ca:
/*
* Callbacks, etc. for session resumption.
*/
@ -36,7 +36,7 @@ Last-Update: 2017-05-30
/*
* Cache sessions on disk if requested.
*/
@@ -3221,7 +3221,7 @@ post_ca:
@@ -3347,7 +3347,7 @@ post_ca:
/*
* Setup session caching
*/


+ 0
- 24
net/freeradius3/patches/004-tls.c-allow-build-with-no-openssl-engine-support.patch View File

@ -1,24 +0,0 @@
From 0b17cf6e39064b008792811a6babf4cd75ac7744 Mon Sep 17 00:00:00 2001
From: Eneas U de Queiroz <cote2004-github@yahoo.com>
Date: Mon, 25 Feb 2019 10:48:48 -0300
Subject: [PATCH] tls.c: allow build with no openssl engine support
This avoids an ENGINE_cleanup call if openssl was compiled without
engine support.
Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
diff --git a/src/main/tls.c b/src/main/tls.c
index 73f0e3a3e8..9726953234 100644
--- a/src/main/tls.c
+++ b/src/main/tls.c
@@ -2743,7 +2743,9 @@ void tls_global_cleanup(void)
#elif OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
ERR_remove_thread_state(NULL);
#endif
+#ifndef OPENSSL_NO_ENGINE
ENGINE_cleanup();
+#endif
CONF_modules_unload(1);
ERR_free_strings();
EVP_cleanup();

Loading…
Cancel
Save