Browse Source

vips: update to 8.10.2

Signed-off-by: W. Michael Petullo <mike@flyn.org>
lilik-openwrt-22.03
W. Michael Petullo 4 years ago
parent
commit
74e30ea924
3 changed files with 20 additions and 22 deletions
  1. +2
    -2
      libs/vips/Makefile
  2. +13
    -11
      libs/vips/patches/001-no_introspection.patch
  3. +5
    -9
      libs/vips/patches/010-reproducible-build.patch

+ 2
- 2
libs/vips/Makefile View File

@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=vips
PKG_VERSION:=8.8.3
PKG_VERSION:=8.10.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/libvips/libvips/releases/download/v$(PKG_VERSION)
PKG_HASH:=c5e4dd5a5c6a777c129037d19ca606769b3f1d405fcc9c8eeda906a61491f790
PKG_HASH:=c1d0d9cb54d75cd4f66dce787fbcac99f834f6621fbf47bce9e02ef65b4ab02a
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
PKG_LICENSE:=LGPL-2.1-or-later


+ 13
- 11
libs/vips/patches/001-no_introspection.patch View File

@ -1,18 +1,20 @@
--- a/configure.ac
+++ b/configure.ac
@@ -53,9 +53,6 @@ AC_SUBST(LIBRARY_CURRENT)
diff -u --recursive vips-8.10.2-vanilla/configure.ac vips-8.10.2/configure.ac
--- vips-8.10.2-vanilla/configure.ac 2020-10-12 11:43:59.000000000 -0500
+++ vips-8.10.2/configure.ac 2020-11-19 12:17:39.393295442 -0600
@@ -53,9 +53,6 @@
AC_SUBST(LIBRARY_REVISION)
AC_SUBST(LIBRARY_AGE)
-# init introspection support
-GOBJECT_INTROSPECTION_CHECK([1.30.0])
-
# gir needs a list of source files to scan for introspection
#
# build with a glob and a list of files to exclude from scanning
--- a/libvips/Makefile.am
+++ b/libvips/Makefile.am
@@ -68,56 +68,3 @@ install-exec-hook:
# remove the '(disabled, use --enable-introspection to enable)'
# suffix from the found_introspection variable
if test "x$found_introspection" != x"yes"; then
diff -u --recursive vips-8.10.2-vanilla/libvips/Makefile.am vips-8.10.2/libvips/Makefile.am
--- vips-8.10.2-vanilla/libvips/Makefile.am 2020-09-14 10:38:03.000000000 -0500
+++ vips-8.10.2/libvips/Makefile.am 2020-11-19 12:18:08.473384766 -0600
@@ -67,56 +67,3 @@
echo "#define VIPS_SONAME \"$$dlname\"" >> soname.h && \
cp soname.h $(DESTDIR)$(pkgincludedir) && \
rm soname.h
@ -35,7 +37,7 @@
-LDADD = @INTROSPECTION_LIBS@ @VIPS_CFLAGS@ libvips.la @VIPS_LIBS@
-
-noinst_PROGRAMS = \
- introspect
- introspect$(EXEEXT)
-introspect_SOURCES = \
- introspect.c
-
@ -44,7 +46,7 @@
-introspection_sources = @vips_introspection_sources@
-
-# we make the vips8 API
-Vips-8.0.gir: introspect
-Vips-8.0.gir: introspect$(EXEEXT)
-Vips_8_0_gir_INCLUDES = GObject-2.0
-Vips_8_0_gir_CFLAGS = $(INCLUDES) -I${top_srcdir}/libvips/include
-Vips_8_0_gir_LIBS = libvips.la


+ 5
- 9
libs/vips/patches/010-reproducible-build.patch View File

@ -1,15 +1,11 @@
Description: Make the build reproducible
Author: Chris Lamb <lamby@debian.org>
Reviewed-By: Laszlo Boszormenyi (GCS) <gcs@debian.org>
Last-Update: 2018-07-24
--- vips-8.6.4.orig/configure.ac
+++ vips-8.6.4/configure.ac
@@ -26,7 +26,11 @@ VIPS_MAJOR_VERSION=vips_major_version()
diff -u --recursive vips-8.10.2-vanilla/configure.ac vips-8.10.2/configure.ac
--- vips-8.10.2-vanilla/configure.ac 2020-10-12 11:43:59.000000000 -0500
+++ vips-8.10.2/configure.ac 2020-11-19 12:16:45.187129100 -0600
@@ -26,7 +26,11 @@
VIPS_MINOR_VERSION=vips_minor_version()
VIPS_MICRO_VERSION=vips_micro_version()
VIPS_VERSION=vips_version()
-VIPS_VERSION_STRING=$VIPS_VERSION-`date -u -r ChangeLog`
-VIPS_VERSION_STRING=$VIPS_VERSION-`date -u -r $srcdir/ChangeLog`
+if test "x$SOURCE_DATE_EPOCH" = "x"; then
+ VIPS_VERSION_STRING=$VIPS_VERSION-`date -u -r ChangeLog`
+else


Loading…
Cancel
Save