Browse Source

hwinfo: refresh patches to avoid fuzz and offset

Fixes:
Applying patch 3-assorted-Makefile-butchery
patching file Makefile
patching file Makefile.common
patching file src/Makefile
patching file src/hd/Makefile
Hunk #1 succeeded at 8 with fuzz 1 (offset -4 lines).
patching file src/isdn/Makefile
patching file src/smp/Makefile

Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
lilik-openwrt-22.03
Josef Schlehofer 4 years ago
parent
commit
743e645b1f
No known key found for this signature in database GPG Key ID: B950216FE4329F4C
3 changed files with 16 additions and 23 deletions
  1. +4
    -7
      utils/hwinfo/patches/1-remove_libx8emu_dependency
  2. +1
    -1
      utils/hwinfo/patches/2-enable-hw-ids-and-disable-generation-of-tiny-hwinfo-headers
  3. +11
    -15
      utils/hwinfo/patches/3-assorted-Makefile-butchery

+ 4
- 7
utils/hwinfo/patches/1-remove_libx8emu_dependency View File

@ -5,9 +5,9 @@ to compile this package with this dependency in OpenWrt due to
host builds and whatnot, we simply remove it and disable this host builds and whatnot, we simply remove it and disable this
functionality in hwinfo. functionality in hwinfo.
This also saves some space. This also saves some space.
--- a/Makefile
+++ b/Makefile
@@ -25,13 +25,14 @@
--- a/Makefile
+++ b/Makefile
@@ -25,13 +25,14 @@ LIBDIR ?= /usr/lib
endif endif
ULIBDIR = $(LIBDIR) ULIBDIR = $(LIBDIR)
@ -28,10 +28,9 @@ This also saves some space.
SHARED_FLAGS = SHARED_FLAGS =
OBJS_NO_TINY = names.o parallel.o modem.o OBJS_NO_TINY = names.o parallel.o modem.o
--- a/src/hd/bios.c --- a/src/hd/bios.c
+++ b/src/hd/bios.c +++ b/src/hd/bios.c
@@ -447,9 +447,10 @@
@@ -447,9 +447,10 @@ void hd_scan_bios(hd_data_t *hd_data)
} }
} }
@ -45,7 +44,6 @@ This also saves some space.
if(vbe->ok) { if(vbe->ok) {
bt->vbe_ver = vbe->version; bt->vbe_ver = vbe->version;
--- a/src/hd/bios.h --- a/src/hd/bios.h
+++ b/src/hd/bios.h +++ b/src/hd/bios.h
@@ -5,4 +5,5 @@ @@ -5,4 +5,5 @@
@ -55,7 +53,6 @@ This also saves some space.
-void get_vbe_info(hd_data_t *hd_data, vbe_info_t *vbe); -void get_vbe_info(hd_data_t *hd_data, vbe_info_t *vbe);
+//disabled as we removed the lib needed by this function +//disabled as we removed the lib needed by this function
+//void get_vbe_info(hd_data_t *hd_data, vbe_info_t *vbe); +//void get_vbe_info(hd_data_t *hd_data, vbe_info_t *vbe);
--- a/src/hd/mdt.c --- a/src/hd/mdt.c
+++ b/src/hd/mdt.c +++ b/src/hd/mdt.c
@@ -1,4 +1,6 @@ @@ -1,4 +1,6 @@


+ 1
- 1
utils/hwinfo/patches/2-enable-hw-ids-and-disable-generation-of-tiny-hwinfo-headers View File

@ -6,7 +6,7 @@ on my OpenSUSE system, so I guess that it is just legacy stuff that bitrotted.
--- a/src/ids/Makefile --- a/src/ids/Makefile
+++ b/src/ids/Makefile +++ b/src/ids/Makefile
@@ -17,47 +17,47 @@
@@ -17,47 +17,47 @@ IDFILES += src/bus src/class src/extra s
src/usb src/usb2 src/isapnp src/monitor src/camera src/tv2 src/tv src/dvb2 src/dvb \ src/usb src/usb2 src/isapnp src/monitor src/camera src/tv2 src/tv src/dvb2 src/dvb \
src/chipcard src/modem src/pcmcia src/s390 src/sdio src/chipcard src/modem src/pcmcia src/s390 src/sdio


+ 11
- 15
utils/hwinfo/patches/3-assorted-Makefile-butchery View File

@ -4,8 +4,8 @@ Some makefile modifications to:
>>disable the install functionality as we take the files we need with OpenWrt build system >>disable the install functionality as we take the files we need with OpenWrt build system
>>changes to all makefiles to respect the compile flags >>changes to all makefiles to respect the compile flags
--- a/Makefile
+++ b/Makefile
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@ @@ -1,6 +1,6 @@
TOPDIR = $(CURDIR) TOPDIR = $(CURDIR)
SUBDIRS = src SUBDIRS = src
@ -14,7 +14,7 @@ Some makefile modifications to:
CLEANFILES = hwinfo hwinfo.pc hwinfo.static hwscan hwscan.static hwscand hwscanqueue doc/libhd doc/*~ CLEANFILES = hwinfo hwinfo.pc hwinfo.static hwscan hwscan.static hwscand hwscanqueue doc/libhd doc/*~
LIBS = -lhd LIBS = -lhd
SLIBS = -lhd -luuid SLIBS = -lhd -luuid
@@ -18,11 +18,11 @@
@@ -18,11 +18,11 @@ PREFIX := hwinfo-$(VERSION)
include Makefile.common include Makefile.common
@ -30,7 +30,7 @@ Some makefile modifications to:
ULIBDIR = $(LIBDIR) ULIBDIR = $(LIBDIR)
# this library has been removed from the code, disabling it here too # this library has been removed from the code, disabling it here too
@@ -39,13 +39,13 @@
@@ -39,13 +39,13 @@ OBJS_NO_TINY = names.o parallel.o modem.
.PHONY: fullstatic static shared tiny doc diet tinydiet uc tinyuc .PHONY: fullstatic static shared tiny doc diet tinydiet uc tinyuc
@ -49,7 +49,7 @@ Some makefile modifications to:
hwscan: hwscan.o $(LIBHD) hwscan: hwscan.o $(LIBHD)
$(CC) hwscan.o $(LDFLAGS) $(CFLAGS) $(LIBS) -o $@ $(CC) hwscan.o $(LDFLAGS) $(CFLAGS) $(LIBS) -o $@
@@ -99,28 +99,29 @@
@@ -99,28 +99,29 @@ doc:
@cd doc ; doxygen libhd.doxy @cd doc ; doxygen libhd.doxy
install: install:
@ -101,7 +101,6 @@ Some makefile modifications to:
archive: changelog archive: changelog
@if [ ! -d .git ] ; then echo no git repo ; false ; fi @if [ ! -d .git ] ; then echo no git repo ; false ; fi
--- a/Makefile.common --- a/Makefile.common
+++ b/Makefile.common +++ b/Makefile.common
@@ -1,28 +1,26 @@ @@ -1,28 +1,26 @@
@ -147,7 +146,7 @@ Some makefile modifications to:
SHARED_FLAGS = -fPIC SHARED_FLAGS = -fPIC
LDFLAGS += -Lsrc LDFLAGS += -Lsrc
@@ -36,7 +34,7 @@
@@ -36,7 +34,7 @@ LIBHD_NAME = $(LIBHD_BASE).so.$(LIBHD_VE
LIBHD_SO = $(TOPDIR)/src/$(LIBHD_NAME) LIBHD_SO = $(TOPDIR)/src/$(LIBHD_NAME)
LIBHD_D = $(TOPDIR)/src/.lib LIBHD_D = $(TOPDIR)/src/.lib
@ -156,10 +155,9 @@ Some makefile modifications to:
.PHONY: all distclean clean install subdirs .PHONY: all distclean clean install subdirs
--- a/src/Makefile --- a/src/Makefile
+++ b/src/Makefile +++ b/src/Makefile
@@ -12,7 +12,7 @@
@@ -12,7 +12,7 @@ include $(TOPDIR)/Makefile.common
#endif #endif
$(LIBHD): $(OBJS) $(LIBHD): $(OBJS)
@ -170,16 +168,15 @@ Some makefile modifications to:
ifdef SHARED_FLAGS ifdef SHARED_FLAGS
--- a/src/hd/Makefile --- a/src/hd/Makefile
+++ b/src/hd/Makefile +++ b/src/hd/Makefile
@@ -12,4 +12,4 @@
@perl -pi -e "s/define\s+HD_MINOR_VERSION\s+\d+/define HD_MINOR_VERSION\t$(LIBHD_MINOR_VERSION)/" $@
@@ -8,4 +8,4 @@ version.h: $(TOPDIR)/VERSION
@echo "#define HD_VERSION_STRING \"`cat $(TOPDIR)/VERSION`\"" >$@
$(LIBHD_D): $(OBJS) $(LIBHD_D): $(OBJS)
- ar r $(LIBHD) $? - ar r $(LIBHD) $?
+ $(AR) r $(LIBHD) $? + $(AR) r $(LIBHD) $?
--- a/src/isdn/Makefile --- a/src/isdn/Makefile
+++ b/src/isdn/Makefile +++ b/src/isdn/Makefile
@@ -5,5 +5,5 @@
@@ -5,5 +5,5 @@ SUBDIRS = cdb
include $(TOPDIR)/Makefile.common include $(TOPDIR)/Makefile.common
$(LIBHD_D): $(OBJS) $(LIBHD_D): $(OBJS)
@ -188,10 +185,9 @@ Some makefile modifications to:
--- a/src/smp/Makefile --- a/src/smp/Makefile
+++ b/src/smp/Makefile +++ b/src/smp/Makefile
@@ -4,4 +4,4 @@
@@ -4,4 +4,4 @@ TARGETS = $(LIBHD_D)
include $(TOPDIR)/Makefile.common include $(TOPDIR)/Makefile.common
$(LIBHD_D): $(OBJS) $(LIBHD_D): $(OBJS)
- ar r $(LIBHD) $? - ar r $(LIBHD) $?
+ $(AR) r $(LIBHD) $? + $(AR) r $(LIBHD) $?

Loading…
Cancel
Save