Browse Source

php5-pecl-dio: move from oldpackages, update and fix build

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
lilik-openwrt-22.03
Michael Heimpold 9 years ago
parent
commit
737da8a5d7
2 changed files with 65 additions and 0 deletions
  1. +36
    -0
      lang/php5-pecl-dio/Makefile
  2. +29
    -0
      lang/php5-pecl-dio/patches/010-additional-baudrates.patch

+ 36
- 0
lang/php5-pecl-dio/Makefile View File

@ -0,0 +1,36 @@
#
# Copyright (C) 2012-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PECL_NAME:=dio
PECL_LONGNAME:=Direct I/O functions
PKG_VERSION:=0.0.7
PKG_RELEASE:=1
PKG_MD5SUM:=a1a4df428a17dbe1ab4277b492dfa052
PKG_NAME:=php5-pecl-$(PECL_NAME)
PKG_SOURCE:=$(PECL_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=http://pecl.php.net/get/
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PECL_NAME)-$(PKG_VERSION)
PKG_BUILD_PARALLEL:=1
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
PKG_LICENSE:=PHPv3.01
PKG_LICENSE_FILES:=
PKG_FIXUP:=autoreconf
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
include ../php5/pecl.mk
$(eval $(call PECLPackage,$(PECL_NAME),$(PECL_LONGNAME)))
$(eval $(call BuildPackage,$(PKG_NAME)))

+ 29
- 0
lang/php5-pecl-dio/patches/010-additional-baudrates.patch View File

@ -0,0 +1,29 @@
--- a/dio.c
+++ b/dio.c
@@ -442,6 +442,26 @@ PHP_FUNCTION(dio_tcsetattr)
/* assign to correct values... */
switch (Baud_Rate) {
+#ifdef B460800
+ case 460800:
+ BAUD = B460800;
+ break;
+#endif
+#ifdef B230400
+ case 230400:
+ BAUD = B230400;
+ break;
+#endif
+#ifdef B115200
+ case 115200:
+ BAUD = B115200;
+ break;
+#endif
+#ifdef B57600
+ case 57600:
+ BAUD = B57600;
+ break;
+#endif
case 38400:
BAUD = B38400;
break;

Loading…
Cancel
Save