Browse Source
Merge pull request #16420 from neheb/fakepop
fakepop: fix compilation with PKG_ASLR
lilik-openwrt-22.03
Rosen Penev
3 years ago
committed by
GitHub
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with
14 additions and
1 deletions
-
net/fakepop/Makefile
-
net/fakepop/patches/010-fPIC.patch
|
|
@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=fakepop |
|
|
|
PKG_VERSION:=11 |
|
|
|
PKG_RELEASE:=1 |
|
|
|
PKG_RELEASE:=2 |
|
|
|
|
|
|
|
PKG_MAINTAINER:=Marc Egerton <foxtrot@realloc.me> |
|
|
|
PKG_LICENSE:=GPL-3.0-or-later |
|
|
|
|
|
@ -0,0 +1,13 @@ |
|
|
|
--- a/Makefile
|
|
|
|
+++ b/Makefile
|
|
|
|
@@ -2,8 +2,8 @@
|
|
|
|
|
|
|
|
GLIB_CFLAGS = $(shell pkg-config --cflags glib-2.0) |
|
|
|
GLIB_LDFLAGS = $(shell pkg-config --libs glib-2.0) |
|
|
|
-CFLAGS = -D_GNU_SOURCE -Wall -O2 $(GLIB_CFLAGS)
|
|
|
|
-LDLIBS = $(GLIB_LDFLAGS)
|
|
|
|
+CFLAGS += $(GLIB_CFLAGS)
|
|
|
|
+LDLIBS += $(GLIB_LDFLAGS)
|
|
|
|
|
|
|
|
all: fakepop |
|
|
|
|