Browse Source

mutt: bring back from oldpackages

* import from oldpackages
* bump version and update hash
* update patch to new version
* add PKG_LICENSE, PKG_LICENSE_FILES, PKG_MAINTAINER

Signed-off-by: Phil Eichinger <phil@zankapfel.net>
lilik-openwrt-22.03
Phil Eichinger 9 years ago
parent
commit
726a734c32
2 changed files with 80 additions and 0 deletions
  1. +53
    -0
      mail/mutt/Makefile
  2. +27
    -0
      mail/mutt/patches/0001-no-po-and-docs.patch

+ 53
- 0
mail/mutt/Makefile View File

@ -0,0 +1,53 @@
#
# Copyright (C) 2006-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=mutt
PKG_VERSION:=1.5.24
PKG_RELEASE:=1
PKG_SOURCE_URL:=ftp://ftp.mutt.org/pub/mutt/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_MD5SUM:=7f25d27f3c7c82285ac07aac35f5f0f2
PKG_LICENSE:=GPL-2.0+
PKG_LICENSE_FILES:=GPL
PKG_MAINTAINER=Phil Eichinger <phil@zankapfel.net>
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
define Package/mutt
SECTION:=mail
CATEGORY:=Mail
DEPENDS:=+libopenssl +libncursesw
TITLE:=Console mail client
URL:=http://www.mutt.org/
endef
define Package/mutt/description
Mutt is a small but very powerful text-based mail client for Unix
operating systems.
endef
CONFIGURE_ARGS += \
--includedir=$(PKG_BUILD_DIR)/. \
--oldincludedir=$(PKG_BUILD_DIR)/. \
--enable-pop \
--enable-imap \
--with-ssl \
--without-idn
define Package/mutt/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mutt $(1)/usr/bin/
endef
$(eval $(call BuildPackage,mutt))

+ 27
- 0
mail/mutt/patches/0001-no-po-and-docs.patch View File

@ -0,0 +1,27 @@
From b0e285a8c7faaec8807fdd677da6750f341f0109 Mon Sep 17 00:00:00 2001
From: Phil Eichinger <phil@zankapfel.net>
Date: Thu, 19 Nov 2015 13:18:53 +0100
Subject: [PATCH] no po and docs
[adapted old patch and converted to git patch]
Signed-off-by: Phil Eichinger <phil@zankapfel.net>
---
Makefile.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile.in b/Makefile.in
index 1909835..cfa7ca0 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -458,7 +458,7 @@ get_cs_cmdline = $(call get_cs_compile,$(1)) $(call get_cs_all_flags,$(1),check_
AUTOMAKE_OPTIONS = 1.6 foreign
@BUILD_IMAP_TRUE@IMAP_SUBDIR = imap
@BUILD_IMAP_TRUE@IMAP_INCLUDES = -I$(top_srcdir)/imap
-SUBDIRS = m4 po intl doc contrib $(IMAP_SUBDIR)
+SUBDIRS = m4 intl contrib $(IMAP_SUBDIR)
bin_SCRIPTS = muttbug flea $(SMIMEAUX_TARGET)
@BUILD_HCACHE_TRUE@HCVERSION = hcversion.h
BUILT_SOURCES = keymap_defs.h patchlist.c reldate.h conststrings.c $(HCVERSION)
--
2.1.4

Loading…
Cancel
Save