Browse Source
Merge pull request #7342 from neheb/uw
uw-imap: Fix compilation without deprecated APIs for OpenSSL
lilik-openwrt-22.03
Hannu Nyman
6 years ago
committed by
GitHub
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with
13 additions and
1 deletions
-
libs/uw-imap/Makefile
-
libs/uw-imap/patches/020-deprecated-openssl.patch
|
|
@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=uw-imap |
|
|
|
PKG_VERSION:=2007f |
|
|
|
PKG_RELEASE:=2 |
|
|
|
PKG_RELEASE:=3 |
|
|
|
|
|
|
|
PKG_SOURCE:=imap-$(PKG_VERSION).tar.gz |
|
|
|
PKG_SOURCE_URL:= \
|
|
|
|
|
|
@ -0,0 +1,12 @@ |
|
|
|
diff --git a/src/osdep/unix/ssl_unix.c b/src/osdep/unix/ssl_unix.c
|
|
|
|
index 3bfdff3..3ed1cb5 100644
|
|
|
|
--- a/src/osdep/unix/ssl_unix.c
|
|
|
|
+++ b/src/osdep/unix/ssl_unix.c
|
|
|
|
@@ -35,6 +35,7 @@
|
|
|
|
#include <bio.h> |
|
|
|
#include <crypto.h> |
|
|
|
#include <rand.h> |
|
|
|
+#include <rsa.h>
|
|
|
|
#undef crypt |
|
|
|
|
|
|
|
#define SSLBUFLEN 8192 |