Browse Source
Merge pull request #13215 from neheb/dcw
libdcwsocket: fix compilation with glibc
lilik-openwrt-22.03
Rosen Penev
4 years ago
committed by
GitHub
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with
13 additions and
1 deletions
-
libs/libdcwsocket/Makefile
-
libs/libdcwsocket/patches/010-glibc.patch
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=libdcwsocket |
|
|
|
PKG_VERSION:=1.1.0 |
|
|
|
PKG_RELEASE:=1 |
|
|
|
PKG_RELEASE:=2 |
|
|
|
|
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz |
|
|
|
PKG_SOURCE_URL:=https://codeload.github.com/ewsi/$(PKG_NAME)/tar.gz/v$(PKG_VERSION)? |
|
|
|
|
|
@ -0,0 +1,12 @@ |
|
|
|
--- a/src/dcwsocket.c.linux
|
|
|
|
+++ b/src/dcwsocket.c.linux
|
|
|
|
@@ -36,6 +36,9 @@
|
|
|
|
#include <linux/filter.h> |
|
|
|
#include <arpa/inet.h> |
|
|
|
|
|
|
|
+#ifndef SO_ATTACH_FILTER
|
|
|
|
+#define SO_ATTACH_FILTER 26
|
|
|
|
+#endif
|
|
|
|
|
|
|
|
#define ETHER_HEADERSIZE 14 |
|
|
|
#define CL3_HEADERSIZE 4 |