Browse Source

znc: allow running without modules

Now that we don't ship any modules by default, znc might be started
without any modules. Unfortunately znc refuses to start without any
modules, so patch out the appropriate check.

Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
lilik-openwrt-22.03
Jonas Gorski 8 years ago
parent
commit
6fccd8801e
3 changed files with 17 additions and 4 deletions
  1. +1
    -1
      net/znc/Makefile
  2. +15
    -0
      net/znc/patches/104-disable-empty-modules-check.patch
  3. +1
    -3
      net/znc/patches/110-add-playback-module.patch

+ 1
- 1
net/znc/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=znc
PKG_VERSION:=1.6.3
PKG_RELEASE:=4
PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://znc.in/releases \


+ 15
- 0
net/znc/patches/104-disable-empty-modules-check.patch View File

@ -0,0 +1,15 @@
--- a/src/main.cpp
+++ b/src/main.cpp
@@ -296,10 +296,12 @@ int main(int argc, char** argv) {
CUtils::PrintStatus(false, "");
CUtils::PrintError("No modules found. Perhaps you didn't install ZNC properly?");
CUtils::PrintError("Read http://wiki.znc.in/Installation for instructions.");
+#if 0
if (!CUtils::GetBoolInput("Do you really want to run ZNC without any modules?", false)) {
CZNC::DestroyInstance();
return 1;
}
+#endif
}
CUtils::PrintStatus(true, "");
}

+ 1
- 3
net/znc/patches/110-add-playback-module.patch View File

@ -1,7 +1,5 @@
Index: znc-1.6.3/modules/playback.cpp
===================================================================
--- /dev/null
+++ znc-1.6.3/modules/playback.cpp
+++ b/modules/playback.cpp
@@ -0,0 +1,288 @@
+/*
+ * Copyright (C) 2015 J-P Nurmi


Loading…
Cancel
Save