Browse Source

Merge pull request #754 from commodo/python-setuptools-fix

Python setuptools fix
lilik-openwrt-22.03
Steven Barth 10 years ago
parent
commit
6f11a72d33
2 changed files with 23 additions and 3 deletions
  1. +3
    -3
      lang/python-setuptools/Makefile
  2. +20
    -0
      lang/python-setuptools/patches/0001-remove-windows-support.patch

+ 3
- 3
lang/python-setuptools/Makefile View File

@ -40,10 +40,10 @@ define Build/Compile
endef
define Build/InstallDev
$(INSTALL_DIR) $(2)$(PYTHON_PKG_DIR)
$(INSTALL_DIR) $(PYTHON_LIB_DIR)
$(CP) \
$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR) \
$(2)$(PYTHON_PKG_DIR)
$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
$(PYTHON_LIB_DIR)
endef
define PyPackage/python-setuptools/install


+ 20
- 0
lang/python-setuptools/patches/0001-remove-windows-support.patch View File

@ -0,0 +1,20 @@
diff --git a/setuptools/dist.py b/setuptools/dist.py
index 6b9d350..1350e8a 100644
--- a/setuptools/dist.py
+++ b/setuptools/dist.py
@@ -15,7 +15,6 @@ from distutils.errors import (DistutilsOptionError, DistutilsPlatformError,
from setuptools.depends import Require
from setuptools.compat import basestring, PY2
-from setuptools import windows_support
import pkg_resources
def _get_unpatched(cls):
@@ -310,7 +309,6 @@ class Distribution(_Distribution):
egg_cache_dir = os.path.join(os.curdir, '.eggs')
if not os.path.exists(egg_cache_dir):
os.mkdir(egg_cache_dir)
- windows_support.hide_file(egg_cache_dir)
readme_txt_filename = os.path.join(egg_cache_dir, 'README.txt')
with open(readme_txt_filename, 'w') as f:
f.write('This directory contains eggs that were downloaded '

Loading…
Cancel
Save