Browse Source

radsecproxy: fix compilation with newer GCC

Errors on uninitialized variable. Only on powerpc64 for some reason.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 2 years ago
parent
commit
6e4bf0deaf
2 changed files with 12 additions and 1 deletions
  1. +1
    -1
      net/radsecproxy/Makefile
  2. +11
    -0
      net/radsecproxy/patches/300-uninit.patch

+ 1
- 1
net/radsecproxy/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=radsecproxy
PKG_VERSION:=1.9.0
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/radsecproxy/radsecproxy/releases/download/$(PKG_VERSION)/


+ 11
- 0
net/radsecproxy/patches/300-uninit.patch View File

@ -0,0 +1,11 @@
--- a/gconfig.c
+++ b/gconfig.c
@@ -119,7 +119,7 @@ FILE *pushgconfpaths(struct gconffile **
int i;
FILE *f = NULL;
glob_t globbuf;
- char *path, *curfile = NULL, *dir;
+ char *path = NULL, *curfile = NULL, *dir;
/* if cfgpath is relative, make it relative to current config */
if (*cfgpath == '/')

Loading…
Cancel
Save