Browse Source

memcached: fix musl build

- thx to alpinelinux for the patch
   (http://git.alpinelinux.org/cgit/aports/plain/main/memcached/musl-includes.patch)
 - remove depency to libenvent and replace it libevent2
   should fix issue #1542

Signed-off-by: heil <heil@terminal-consulting.de>
lilik-openwrt-22.03
heil 9 years ago
parent
commit
6cc0ad6ecd
2 changed files with 49 additions and 2 deletions
  1. +2
    -2
      net/memcached/Makefile
  2. +47
    -0
      net/memcached/patches/001-musl-compat.patch

+ 2
- 2
net/memcached/Makefile View File

@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=memcached
PKG_VERSION:=1.4.24
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://memcached.org/files
@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/memcached
SECTION:=net
CATEGORY:=Network
DEPENDS:=+libevent +libpthread
DEPENDS:=+libevent2 +libpthread
TITLE:=The high-performance, distributed memory object caching system
URL:=http://memcached.org/
endef


+ 47
- 0
net/memcached/patches/001-musl-compat.patch View File

@ -0,0 +1,47 @@
--- memcached-1.4.15.orig/assoc.c
+++ memcached-1.4.15/assoc.c
@@ -14,8 +14,8 @@
#include "memcached.h"
#include <sys/stat.h>
#include <sys/socket.h>
-#include <sys/signal.h>
#include <sys/resource.h>
+#include <signal.h>
#include <fcntl.h>
#include <netinet/in.h>
#include <errno.h>
--- memcached-1.4.15.orig/items.c
+++ memcached-1.4.15/items.c
@@ -2,13 +2,13 @@
#include "memcached.h"
#include <sys/stat.h>
#include <sys/socket.h>
-#include <sys/signal.h>
#include <sys/resource.h>
#include <fcntl.h>
#include <netinet/in.h>
#include <errno.h>
#include <stdlib.h>
#include <stdio.h>
+#include <signal.h>
#include <string.h>
#include <time.h>
#include <assert.h>
--- memcached-1.4.15.orig/slabs.c
+++ memcached-1.4.15/slabs.c
@@ -10,7 +10,6 @@
#include "memcached.h"
#include <sys/stat.h>
#include <sys/socket.h>
-#include <sys/signal.h>
#include <sys/resource.h>
#include <fcntl.h>
#include <netinet/in.h>
@@ -18,6 +17,7 @@
#include <stdlib.h>
#include <stdio.h>
#include <string.h>
+#include <signal.h>
#include <assert.h>
#include <pthread.h>

Loading…
Cancel
Save