Browse Source

vim: fix compilation with macOS

Upstream backport.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 3 years ago
parent
commit
6c73457c09
2 changed files with 40 additions and 1 deletions
  1. +1
    -1
      utils/vim/Makefile
  2. +39
    -0
      utils/vim/patches/020-macos.patch

+ 1
- 1
utils/vim/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=vim
PKG_VERSION:=8.2
PKG_RELEASE:=4
PKG_RELEASE:=5
VIMVER:=82
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2


+ 39
- 0
utils/vim/patches/020-macos.patch View File

@ -0,0 +1,39 @@
From 5289783e0b07cfc3f92ee933261ca4c4acdca007 Mon Sep 17 00:00:00 2001
From: Bram Moolenaar <Bram@vim.org>
Date: Thu, 2 Jul 2020 22:50:37 +0200
Subject: [PATCH] patch 8.2.1119: configure fails with Xcode 12 beta
Problem: Configure fails with Xcode 12 beta.
Solution: use "return" instead of "exit()". (Nico Weber, closes #6381)
---
src/auto/configure | 4 ++--
src/configure.ac | 4 ++--
src/version.c | 2 ++
3 files changed, 6 insertions(+), 4 deletions(-)
--- a/src/auto/configure
+++ b/src/auto/configure
@@ -14005,8 +14005,8 @@ else
main() {
uint32_t nr1 = (uint32_t)-1;
uint32_t nr2 = (uint32_t)0xffffffffUL;
- if (sizeof(uint32_t) != 4 || nr1 != 0xffffffffUL || nr2 + 1 != 0) exit(1);
- exit(0);
+ if (sizeof(uint32_t) != 4 || nr1 != 0xffffffffUL || nr2 + 1 != 0) return 1;
+ return 0;
}
_ACEOF
if ac_fn_c_try_run "$LINENO"; then :
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4129,8 +4129,8 @@ AC_TRY_RUN([
main() {
uint32_t nr1 = (uint32_t)-1;
uint32_t nr2 = (uint32_t)0xffffffffUL;
- if (sizeof(uint32_t) != 4 || nr1 != 0xffffffffUL || nr2 + 1 != 0) exit(1);
- exit(0);
+ if (sizeof(uint32_t) != 4 || nr1 != 0xffffffffUL || nr2 + 1 != 0) return 1;
+ return 0;
}],
AC_MSG_RESULT(ok),
AC_MSG_ERROR([WRONG! uint32_t not defined correctly.]),

Loading…
Cancel
Save