Browse Source

hwinfo: fix compilation with ARC

Added a small patch to fix compilation.

Renamed patch files to have a .patch suffix. Makes them easier to read
with vim and probably IDEs.

Remove UCLIBC depend since it's no longer present.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 3 years ago
parent
commit
6af7fbbf01
6 changed files with 15 additions and 2 deletions
  1. +2
    -2
      utils/hwinfo/Makefile
  2. +0
    -0
      utils/hwinfo/patches/010-hardcoding-version.patch
  3. +0
    -0
      utils/hwinfo/patches/020-remove_libx8emu_dependency.patch
  4. +0
    -0
      utils/hwinfo/patches/030-enable-hw-ids-and-disable-generation-of-tiny-hwinfo-headers.patch
  5. +0
    -0
      utils/hwinfo/patches/040-assorted-Makefile-butchery.patch
  6. +13
    -0
      utils/hwinfo/patches/050-arc.patch

+ 2
- 2
utils/hwinfo/Makefile View File

@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=hwinfo
PKG_VERSION:=21.71
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/openSUSE/hwinfo/tar.gz/$(PKG_VERSION)?
@ -66,7 +66,7 @@ define Package/hwinfo
CATEGORY:=Utilities
TITLE:=probe the hardware present in the system
URL:=https://github.com/openSUSE/hwinfo
DEPENDS:= +libuuid @!USE_UCLIBC
DEPENDS:= +libuuid
endef
define Package/hwinfo/description


utils/hwinfo/patches/0-hardcoding-version → utils/hwinfo/patches/010-hardcoding-version.patch View File


utils/hwinfo/patches/1-remove_libx8emu_dependency → utils/hwinfo/patches/020-remove_libx8emu_dependency.patch View File


utils/hwinfo/patches/2-enable-hw-ids-and-disable-generation-of-tiny-hwinfo-headers → utils/hwinfo/patches/030-enable-hw-ids-and-disable-generation-of-tiny-hwinfo-headers.patch View File


utils/hwinfo/patches/3-assorted-Makefile-butchery → utils/hwinfo/patches/040-assorted-Makefile-butchery.patch View File


+ 13
- 0
utils/hwinfo/patches/050-arc.patch View File

@ -0,0 +1,13 @@
--- a/src/hd/hd.c
+++ b/src/hd/hd.c
@@ -156,6 +156,10 @@
#define HD_ARCH "riscv"
#endif
+#ifdef __arc__
+#define HD_ARCH "arc"
+#endif
+
typedef struct disk_s {
struct disk_s *next;
unsigned crc;

Loading…
Cancel
Save