Browse Source

Merge pull request #7730 from ja-pa/unbound-dns64-patch

unbound: add patch to fix dns64 crash
lilik-openwrt-22.03
Hannu Nyman 6 years ago
committed by GitHub
parent
commit
69a7c970cf
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 24 additions and 1 deletions
  1. +1
    -1
      net/unbound/Makefile
  2. +23
    -0
      net/unbound/patches/101-dns64-crash.patch

+ 1
- 1
net/unbound/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=unbound
PKG_VERSION:=1.8.3
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE


+ 23
- 0
net/unbound/patches/101-dns64-crash.patch View File

@ -0,0 +1,23 @@
From 023411f97505c8c7e375112ad853b6a40ef848a6 Mon Sep 17 00:00:00 2001
From: Wouter Wijngaards <wouter@nlnetlabs.nl>
Date: Wed, 12 Dec 2018 16:03:05 +0000
Subject: [PATCH] - Fix for crash in dns64 module if response is null.
git-svn-id: file:///svn/unbound/trunk@5025 be551aaa-1e26-0410-a405-d3ace91eadb9
---
dns64/dns64.c | 1 +
doc/Changelog | 3 +++
2 files changed, 4 insertions(+)
diff --git a/dns64/dns64.c b/dns64/dns64.c
index 77e68900..f2834da2 100644
--- a/dns64/dns64.c
+++ b/dns64/dns64.c
@@ -628,6 +628,7 @@ handle_event_moddone(struct module_qstate* qstate, int id)
/* Store the response in cache. */
if ( (!iq || !iq->started_no_cache_store) &&
+ qstate->return_msg && qstate->return_msg->rep &&
!dns_cache_store(qstate->env, &qstate->qinfo, qstate->return_msg->rep,
0, 0, 0, NULL, qstate->query_flags))
log_err("out of memory");

Loading…
Cancel
Save