Browse Source

stress: replace usleep with nanosleep

The former is deprecated.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 4 years ago
parent
commit
69239158c9
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 47 additions and 1 deletions
  1. +1
    -1
      utils/stress/Makefile
  2. +46
    -0
      utils/stress/patches/010-usleep.patch

+ 1
- 1
utils/stress/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=stress
PKG_VERSION:=1.0.4
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://fossies.org/linux/privat


+ 46
- 0
utils/stress/patches/010-usleep.patch View File

@ -0,0 +1,46 @@
--- a/src/stress.c
+++ b/src/stress.c
@@ -262,6 +262,7 @@ main (int argc, char **argv)
/* Calculate the backoff value so we get good fork throughput. */
backoff = do_backoff * forks;
+ struct timespec b = {backoff / 1000000, (backoff % 1000000) * 1000};
dbg (stdout, "using backoff sleep of %llius\n", backoff);
/* If we are supposed to respect a timeout, calculate it. */
@@ -296,7 +297,7 @@ main (int argc, char **argv)
{
case 0: /* child */
alarm (timeout);
- usleep (backoff);
+ nanosleep(&b, NULL);
if (do_dryrun)
exit (0);
exit (hogcpu ());
@@ -317,7 +318,7 @@ main (int argc, char **argv)
{
case 0: /* child */
alarm (timeout);
- usleep (backoff);
+ nanosleep(&b,&b);
if (do_dryrun)
exit (0);
exit (hogio ());
@@ -337,7 +338,7 @@ main (int argc, char **argv)
{
case 0: /* child */
alarm (timeout);
- usleep (backoff);
+ nanosleep(&b, &b);
if (do_dryrun)
exit (0);
exit (hogvm
@@ -358,7 +359,7 @@ main (int argc, char **argv)
{
case 0: /* child */
alarm (timeout);
- usleep (backoff);
+ nanosleep(&b, &b);
if (do_dryrun)
exit (0);
exit (hoghdd (do_hdd_bytes));

Loading…
Cancel
Save