Browse Source

xtables-addons: update to 3.5

Add xt_PROTO target.

Signed-off-by: DENG Qingfang <dengqf6@mail2.sysu.edu.cn>
lilik-openwrt-22.03
DENG Qingfang 5 years ago
parent
commit
685fe876be
5 changed files with 17 additions and 16 deletions
  1. +3
    -2
      net/xtables-addons/Makefile
  2. +3
    -3
      net/xtables-addons/patches/002-restore-support-for-Linux-4.14.patch
  3. +6
    -6
      net/xtables-addons/patches/003-restore-support-for-Linux-4.9.patch
  4. +2
    -2
      net/xtables-addons/patches/100-add-rtsp-conntrack.patch
  5. +3
    -3
      net/xtables-addons/patches/200-add-lua-packetscript.patch

+ 3
- 2
net/xtables-addons/Makefile View File

@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=xtables-addons PKG_NAME:=xtables-addons
PKG_VERSION:=3.3
PKG_VERSION:=3.5
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_HASH:=efa62c7df6cd3b82d7195105bf6fe177b605f91f3522e4114d2f4e0ad54320d6
PKG_HASH:=189ff57a0b8960969bd99141a6c79c345efa67e4461f450e2f162c9bd3d17da6
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@SF/xtables-addons PKG_SOURCE_URL:=@SF/xtables-addons
@ -170,6 +170,7 @@ $(eval $(call BuildTemplate,length2,length2,xt_length2,xt_length2,+kmod-ipt-comp
$(eval $(call BuildTemplate,logmark,LOGMARK,xt_LOGMARK,xt_LOGMARK,+kmod-ipt-compat-xtables)) $(eval $(call BuildTemplate,logmark,LOGMARK,xt_LOGMARK,xt_LOGMARK,+kmod-ipt-compat-xtables))
$(eval $(call BuildTemplate,lscan,lscan,xt_lscan,xt_lscan,)) $(eval $(call BuildTemplate,lscan,lscan,xt_lscan,xt_lscan,))
$(eval $(call BuildTemplate,lua,Lua PacketScript,xt_LUA,LUA/xt_LUA,+kmod-ipt-conntrack-extra)) $(eval $(call BuildTemplate,lua,Lua PacketScript,xt_LUA,LUA/xt_LUA,+kmod-ipt-conntrack-extra))
$(eval $(call BuildTemplate,proto,PROTO,xt_PROTO,xt_PROTO,))
$(eval $(call BuildTemplate,psd,psd,xt_psd,xt_psd,)) $(eval $(call BuildTemplate,psd,psd,xt_psd,xt_psd,))
$(eval $(call BuildTemplate,quota2,quota2,xt_quota2,xt_quota2,)) $(eval $(call BuildTemplate,quota2,quota2,xt_quota2,xt_quota2,))
$(eval $(call BuildTemplate,sysrq,SYSRQ,xt_SYSRQ,xt_SYSRQ,+kmod-ipt-compat-xtables +kmod-crypto-hash)) $(eval $(call BuildTemplate,sysrq,SYSRQ,xt_SYSRQ,xt_SYSRQ,+kmod-ipt-compat-xtables +kmod-crypto-hash))


+ 3
- 3
net/xtables-addons/patches/002-restore-support-for-Linux-4.14.patch View File

@ -10,10 +10,10 @@ diff --git a/configure.ac b/configure.ac
index 7631f6b..0d3aa72 100644 index 7631f6b..0d3aa72 100644
--- a/configure.ac --- a/configure.ac
+++ b/configure.ac +++ b/configure.ac
@@ -59,7 +59,7 @@ if test -n "$kbuilddir"; then
echo "$kmajor.$kminor.$kmicro.$kstable in $kbuilddir";
if test "$kmajor" -gt 5 -o "$kmajor" -eq 5 -a "$kminor" -gt 0; then
@@ -61,7 +61,7 @@ if test -n "$kbuilddir"; then
echo "WARNING: That kernel version is not officially supported yet. Continue at own luck."; echo "WARNING: That kernel version is not officially supported yet. Continue at own luck.";
elif test "$kmajor" -eq 5 -a "$kminor" -ge 0; then
:
- elif test "$kmajor" -eq 4 -a "$kminor" -ge 18; then - elif test "$kmajor" -eq 4 -a "$kminor" -ge 18; then
+ elif test "$kmajor" -eq 4 -a "$kminor" -ge 14; then + elif test "$kmajor" -eq 4 -a "$kminor" -ge 14; then
: :


+ 6
- 6
net/xtables-addons/patches/003-restore-support-for-Linux-4.9.patch View File

@ -23,10 +23,10 @@ diff --git a/configure.ac b/configure.ac
index 0d3aa72..1cea354 100644 index 0d3aa72..1cea354 100644
--- a/configure.ac --- a/configure.ac
+++ b/configure.ac +++ b/configure.ac
@@ -59,7 +59,7 @@ if test -n "$kbuilddir"; then
echo "$kmajor.$kminor.$kmicro.$kstable in $kbuilddir";
if test "$kmajor" -gt 5 -o "$kmajor" -eq 5 -a "$kminor" -gt 0; then
@@ -61,7 +61,7 @@ if test -n "$kbuilddir"; then
echo "WARNING: That kernel version is not officially supported yet. Continue at own luck."; echo "WARNING: That kernel version is not officially supported yet. Continue at own luck.";
elif test "$kmajor" -eq 5 -a "$kminor" -ge 0; then
:
- elif test "$kmajor" -eq 4 -a "$kminor" -ge 14; then - elif test "$kmajor" -eq 4 -a "$kminor" -ge 14; then
+ elif test "$kmajor" -eq 4 -a "$kminor" -ge 9; then + elif test "$kmajor" -eq 4 -a "$kminor" -ge 9; then
: :
@ -141,7 +141,7 @@ diff --git a/extensions/xt_DELUDE.c b/extensions/xt_DELUDE.c
index 618de5e..221f342 100644 index 618de5e..221f342 100644
--- a/extensions/xt_DELUDE.c --- a/extensions/xt_DELUDE.c
+++ b/extensions/xt_DELUDE.c +++ b/extensions/xt_DELUDE.c
@@ -146,7 +146,13 @@ delude_tg(struct sk_buff *skb, const struct xt_action_param *par)
@@ -151,7 +151,13 @@ delude_tg(struct sk_buff *skb, const struct xt_action_param *par)
* a problem, as that is supported since Linux 2.6.35. But since we do not * a problem, as that is supported since Linux 2.6.35. But since we do not
* actually want to have a connection open, we are still going to drop it. * actually want to have a connection open, we are still going to drop it.
*/ */
@ -243,7 +243,7 @@ diff --git a/extensions/xt_TARPIT.c b/extensions/xt_TARPIT.c
index cb98e9e..b78683c 100644 index cb98e9e..b78683c 100644
--- a/extensions/xt_TARPIT.c --- a/extensions/xt_TARPIT.c
+++ b/extensions/xt_TARPIT.c +++ b/extensions/xt_TARPIT.c
@@ -431,7 +431,12 @@ tarpit_tg4(struct sk_buff *skb, const struct xt_action_param *par)
@@ -436,7 +436,12 @@ tarpit_tg4(struct sk_buff *skb, const struct xt_action_param *par)
/* We are not interested in fragments */ /* We are not interested in fragments */
if (iph->frag_off & htons(IP_OFFSET)) if (iph->frag_off & htons(IP_OFFSET))
return NF_DROP; return NF_DROP;
@ -256,7 +256,7 @@ index cb98e9e..b78683c 100644
return NF_DROP; return NF_DROP;
} }
@@ -472,7 +477,12 @@ tarpit_tg6(struct sk_buff *skb, const struct xt_action_param *par)
@@ -477,7 +482,12 @@ tarpit_tg6(struct sk_buff *skb, const struct xt_action_param *par)
pr_debug("addr is not unicast.\n"); pr_debug("addr is not unicast.\n");
return NF_DROP; return NF_DROP;
} }


+ 2
- 2
net/xtables-addons/patches/100-add-rtsp-conntrack.patch View File

@ -1715,7 +1715,7 @@
+module_exit(fini); +module_exit(fini);
--- a/extensions/Kbuild --- a/extensions/Kbuild
+++ b/extensions/Kbuild +++ b/extensions/Kbuild
@@ -26,6 +26,7 @@ obj-${build_lscan} += xt_lscan.o
@@ -27,6 +27,7 @@ obj-${build_lscan} += xt_lscan.o
obj-${build_pknock} += pknock/ obj-${build_pknock} += pknock/
obj-${build_psd} += xt_psd.o obj-${build_psd} += xt_psd.o
obj-${build_quota2} += xt_quota2.o obj-${build_quota2} += xt_quota2.o
@ -1725,7 +1725,7 @@
-include ${M}/Kbuild.* -include ${M}/Kbuild.*
--- a/mconfig --- a/mconfig
+++ b/mconfig +++ b/mconfig
@@ -22,3 +22,4 @@ build_lscan=m
@@ -23,3 +23,4 @@ build_lscan=m
build_pknock=m build_pknock=m
build_psd=m build_psd=m
build_quota2=m build_quota2=m


+ 3
- 3
net/xtables-addons/patches/200-add-lua-packetscript.patch View File

@ -18134,7 +18134,7 @@
+ +
--- a/extensions/Kbuild --- a/extensions/Kbuild
+++ b/extensions/Kbuild +++ b/extensions/Kbuild
@@ -27,6 +27,7 @@ obj-${build_pknock} += pknock/
@@ -28,6 +28,7 @@ obj-${build_pknock} += pknock/
obj-${build_psd} += xt_psd.o obj-${build_psd} += xt_psd.o
obj-${build_quota2} += xt_quota2.o obj-${build_quota2} += xt_quota2.o
obj-${build_rtsp} += rtsp/ obj-${build_rtsp} += rtsp/
@ -18144,14 +18144,14 @@
-include ${M}/Kbuild.* -include ${M}/Kbuild.*
--- a/extensions/Mbuild --- a/extensions/Mbuild
+++ b/extensions/Mbuild +++ b/extensions/Mbuild
@@ -22,3 +22,4 @@ obj-${build_pknock} += pknock/
@@ -23,3 +23,4 @@ obj-${build_pknock} += pknock/
obj-${build_psd} += libxt_psd.so obj-${build_psd} += libxt_psd.so
obj-${build_quota2} += libxt_quota2.so obj-${build_quota2} += libxt_quota2.so
obj-${build_gradm} += libxt_gradm.so obj-${build_gradm} += libxt_gradm.so
+obj-${build_LUA} += LUA/ +obj-${build_LUA} += LUA/
--- a/mconfig --- a/mconfig
+++ b/mconfig +++ b/mconfig
@@ -23,3 +23,4 @@ build_pknock=m
@@ -24,3 +24,4 @@ build_pknock=m
build_psd=m build_psd=m
build_quota2=m build_quota2=m
build_rtsp=m build_rtsp=m


Loading…
Cancel
Save