|
@ -1,22 +1,24 @@ |
|
|
--- a/Makefile.in
|
|
|
|
|
|
+++ b/Makefile.in
|
|
|
|
|
|
@@ -2441,7 +2441,7 @@ unit_tests = $(am__append_35) unit/test-
|
|
|
|
|
|
|
|
|
--- a/Makefile.in 2017-09-14 11:47:06.000000000 +0200
|
|
|
|
|
|
+++ b/Makefile.in 2017-09-15 02:52:39.315926972 +0200
|
|
|
|
|
|
@@ -2447,7 +2447,7 @@
|
|
|
@CLIENT_TRUE@ monitor/uuid.h monitor/uuid.c |
|
|
@CLIENT_TRUE@ monitor/uuid.h monitor/uuid.c |
|
|
|
|
|
|
|
|
@CLIENT_TRUE@client_bluetoothctl_LDADD = gdbus/libgdbus-internal.la @GLIB_LIBS@ @DBUS_LIBS@ \ |
|
|
|
|
|
-@CLIENT_TRUE@ -lreadline
|
|
|
|
|
|
+@CLIENT_TRUE@ -lreadline -lncurses
|
|
|
|
|
|
|
|
|
@CLIENT_TRUE@client_bluetoothctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \ |
|
|
|
|
|
-@CLIENT_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -lreadline
|
|
|
|
|
|
+@CLIENT_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -lreadline -lncurses
|
|
|
|
|
|
|
|
|
@MONITOR_TRUE@monitor_btmon_SOURCES = monitor/main.c monitor/bt.h \ |
|
|
|
|
|
@MONITOR_TRUE@ monitor/display.h monitor/display.c \ |
|
|
|
|
|
@@ -2691,13 +2691,13 @@ unit_tests = $(am__append_35) unit/test-
|
|
|
|
|
|
@READLINE_TRUE@ client/display.h |
|
|
|
|
|
|
|
|
@MESH_TRUE@mesh_meshctl_SOURCES = mesh/main.c \ |
|
|
|
|
|
@MESH_TRUE@ mesh/mesh-net.h \ |
|
|
|
|
|
@@ -2468,7 +2468,7 @@
|
|
|
|
|
|
|
|
|
@READLINE_TRUE@attrib_gatttool_LDADD = lib/libbluetooth-internal.la \ |
|
|
|
|
|
-@READLINE_TRUE@ src/libshared-glib.la @GLIB_LIBS@ -lreadline
|
|
|
|
|
|
+@READLINE_TRUE@ src/libshared-glib.la @GLIB_LIBS@ -lreadline -lncurses
|
|
|
|
|
|
|
|
|
@MESH_TRUE@mesh_meshctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \ |
|
|
|
|
|
@MESH_TRUE@ lib/libbluetooth-internal.la \ |
|
|
|
|
|
-@MESH_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -ljson-c -lreadline
|
|
|
|
|
|
+@MESH_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -ljson-c -lreadline -lncurses
|
|
|
|
|
|
|
|
|
@READLINE_TRUE@tools_obex_client_tool_SOURCES = $(gobex_sources) $(btio_sources) \ |
|
|
|
|
|
|
|
|
@MONITOR_TRUE@monitor_btmon_SOURCES = monitor/main.c monitor/bt.h \ |
|
|
|
|
|
@MONITOR_TRUE@ monitor/display.h monitor/display.c \ |
|
|
|
|
|
@@ -2724,7 +2724,7 @@
|
|
|
@READLINE_TRUE@ tools/obex-client-tool.c |
|
|
@READLINE_TRUE@ tools/obex-client-tool.c |
|
|
|
|
|
|
|
|
@READLINE_TRUE@tools_obex_client_tool_LDADD = lib/libbluetooth-internal.la \ |
|
|
@READLINE_TRUE@tools_obex_client_tool_LDADD = lib/libbluetooth-internal.la \ |
|
@ -25,7 +27,7 @@ |
|
|
|
|
|
|
|
|
@READLINE_TRUE@tools_obex_server_tool_SOURCES = $(gobex_sources) $(btio_sources) \ |
|
|
@READLINE_TRUE@tools_obex_server_tool_SOURCES = $(gobex_sources) $(btio_sources) \ |
|
|
@READLINE_TRUE@ tools/obex-server-tool.c |
|
|
@READLINE_TRUE@ tools/obex-server-tool.c |
|
|
@@ -2707,17 +2707,17 @@ unit_tests = $(am__append_35) unit/test-
|
|
|
|
|
|
|
|
|
@@ -2734,17 +2734,17 @@
|
|
|
@READLINE_TRUE@ client/display.h client/display.c |
|
|
@READLINE_TRUE@ client/display.h client/display.c |
|
|
|
|
|
|
|
|
@READLINE_TRUE@tools_bluetooth_player_LDADD = gdbus/libgdbus-internal.la \ |
|
|
@READLINE_TRUE@tools_bluetooth_player_LDADD = gdbus/libgdbus-internal.la \ |
|
@ -44,5 +46,14 @@ |
|
|
-@READLINE_TRUE@ -lreadline
|
|
|
-@READLINE_TRUE@ -lreadline
|
|
|
+@READLINE_TRUE@ -lreadline -lncurses
|
|
|
+@READLINE_TRUE@ -lreadline -lncurses
|
|
|
|
|
|
|
|
|
@EXPERIMENTAL_TRUE@tools_gatt_service_SOURCES = tools/gatt-service.c |
|
|
|
|
|
@EXPERIMENTAL_TRUE@tools_gatt_service_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ gdbus/libgdbus-internal.la |
|
|
|
|
|
|
|
|
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_SOURCES = attrib/gatttool.c attrib/att.c attrib/gatt.c \ |
|
|
|
|
|
@DEPRECATED_TRUE@@READLINE_TRUE@ attrib/gattrib.c btio/btio.c \ |
|
|
|
|
|
@@ -2753,7 +2753,7 @@
|
|
|
|
|
|
@DEPRECATED_TRUE@@READLINE_TRUE@ client/display.h |
|
|
|
|
|
|
|
|
|
|
|
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_LDADD = lib/libbluetooth-internal.la \ |
|
|
|
|
|
-@DEPRECATED_TRUE@@READLINE_TRUE@ src/libshared-glib.la @GLIB_LIBS@ -lreadline
|
|
|
|
|
|
+@DEPRECATED_TRUE@@READLINE_TRUE@ src/libshared-glib.la @GLIB_LIBS@ -lreadline -lncurses
|
|
|
|
|
|
|
|
|
|
|
|
@CUPS_TRUE@cupsdir = $(libdir)/cups/backend |
|
|
|
|
|
@CUPS_TRUE@profiles_cups_bluetooth_SOURCES = profiles/cups/main.c \ |