Browse Source

transmission: build with wolfSSL again

The problem was discovered and is now patched with an upstream backport.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 3 years ago
committed by Daniel Golle
parent
commit
6786e35ff8
2 changed files with 27 additions and 3 deletions
  1. +3
    -3
      net/transmission/Makefile
  2. +24
    -0
      net/transmission/patches/030-wolfssl.patch

+ 3
- 3
net/transmission/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=transmission
PKG_VERSION:=3.00
PKG_RELEASE:=14
PKG_RELEASE:=15
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GITHUB/transmission/transmission-releases/master
@ -40,7 +40,7 @@ define Package/transmission/template
CATEGORY:=Network
TITLE:=BitTorrent client
URL:=https://www.transmissionbt.com
DEPENDS:=+libcurl +libevent2 +libminiupnpc +libnatpmp +libpthread +librt +zlib +LIBCURL_NOSSL:libmbedtls +LIBCURL_GNUTLS:libmbedtls +LIBCURL_WOLFSSL:libmbedtls $(ICONV_DEPENDS)
DEPENDS:=+libcurl +libevent2 +libminiupnpc +libnatpmp +libpthread +librt +zlib +LIBCURL_NOSSL:libmbedtls +LIBCURL_GNUTLS:libmbedtls $(ICONV_DEPENDS)
endef
define Package/transmission-daemon
@ -104,7 +104,7 @@ CONFIGURE_ARGS += \
$(if $(CONFIG_LIBCURL_GNUTLS),--with-crypto=polarssl) \
$(if $(CONFIG_LIBCURL_MBEDTLS),--with-crypto=polarssl) \
$(if $(CONFIG_LIBCURL_OPENSSL),--with-crypto=openssl) \
$(if $(CONFIG_LIBCURL_WOLFSSL),--with-crypto=polarssl)
$(if $(CONFIG_LIBCURL_WOLFSSL),--with-crypto=cyassl)
define Package/transmission-daemon/install
$(INSTALL_DIR) $(1)/usr/bin


+ 24
- 0
net/transmission/patches/030-wolfssl.patch View File

@ -0,0 +1,24 @@
From 82b5d4028885d75adba9b66d43aeb11592e64914 Mon Sep 17 00:00:00 2001
From: Rosen Penev <rosenp@gmail.com>
Date: Wed, 13 Oct 2021 18:16:55 -0700
Subject: [PATCH] fix runtime with wolfSSL and fastmath
wolfSSL's fastmath support requires options.h to be included before
anything else. Otherwise bad codepaths get taken and a crash occurs
during DH initialization.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
libtransmission/crypto-utils-cyassl.c | 1 +
1 file changed, 1 insertion(+)
--- a/libtransmission/crypto-utils-cyassl.c
+++ b/libtransmission/crypto-utils-cyassl.c
@@ -19,6 +19,7 @@
#define API_VERSION_HEX LIBCYASSL_VERSION_HEX
#endif
+#include API_HEADER(options.h)
#include API_HEADER_CRYPT(arc4.h)
#include API_HEADER_CRYPT(dh.h)
#include API_HEADER_CRYPT(error-crypt.h)

Loading…
Cancel
Save