Browse Source

fuse: fix compilation with recent glibc

closefrom is implemented now.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 2 years ago
parent
commit
6710881cbd
2 changed files with 21 additions and 1 deletions
  1. +1
    -1
      utils/fuse/Makefile
  2. +20
    -0
      utils/fuse/patches/300-closefrom.patch

+ 1
- 1
utils/fuse/Makefile View File

@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=fuse
PKG_VERSION:=2.9.9
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/libfuse/libfuse/releases/download/$(PKG_NAME)-$(PKG_VERSION)


+ 20
- 0
utils/fuse/patches/300-closefrom.patch View File

@ -0,0 +1,20 @@
--- a/util/ulockmgr_server.c
+++ b/util/ulockmgr_server.c
@@ -124,7 +124,7 @@ static int receive_message(int sock, voi
return res;
}
-static int closefrom(int minfd)
+static int closefrom2(int minfd)
{
DIR *dir = opendir("/proc/self/fd");
if (dir) {
@@ -384,7 +384,7 @@ int main(int argc, char *argv[])
dup2(nullfd, 1);
}
close(3);
- closefrom(5);
+ closefrom2(5);
while (1) {
char c;
int sock;

Loading…
Cancel
Save